DisplayLink Forum

DisplayLink Forum (https://displaylink.org/forum/index.php)
-   Windows Software (https://displaylink.org/forum/forumdisplay.php?f=28)
-   -   Sony Vaio Stamina/Speed Mode - atikmpag.sys BSOD (https://displaylink.org/forum/showthread.php?t=1762)

n0cud06 06-19-2012 03:51 AM

Sony Vaio Stamina/Speed Mode - atikmpag.sys BSOD
 
Fist of all I did search and found a thread related to this but looks like it's now close so I apologize for creating a new one. I'm using Windows 7 Professional in case it matters to anyone.

Anyway, I found a way around my issue but thought you guys might be able to help fix it or make my life easier. My Sony Vaio Series S i5 is equipped with two graphic cards, one from intel used under Stamina mode and one from AMD Radeon used under Speed mode.

It has a toggle switch to go back and forth and it has always worked fine in fact I use Intel Widi on a regular basis and it only works under Stamina mode. Anyway, I bought a Targus Superspeed USB 3.0 Dual Video docking station and as soon as I installed the driver I started getting the BSOD when under Speed mode. Basically on speed mode (AMD Radeon 6340M) I get a blue screen "ATIKMPAG.SYS" and I have to hold power button to shut it down its the only way.

Anyway it works fine under Stamina (Intel HD Graphic Family) and I have done everything I could think of to get it working with the AMD Radeon drivers: Updated all drivers, removed drivers and reinstalled including both graphic cards, USB 3.0 controller, Display Link driver, remove AMD CCC, deleted regs etc.. nothing worked.

Luckly after playing with it all night. I found out that when I get the blue screen after switching to Speed mode I have to hold the power button to shutdown then it reboots and I have the option to go on Safe Mode. Well it turns out that when I switch to Stamina it disconnect AMD Graphics hardware and for some reason the Displaylink driver won't allow the computer to anable it after reconnecting the harware. So when you switch back to speed the computer will reconnect the card but for some reason the card is disable. I have to manually re-enable the card in safe mode then reboot the computer. From there everything works fine but its a real hassle when you are doing that multiple times a day.

Wim 06-19-2012 03:46 PM

Which DL software versions does this happen with? Is it just v6.3, or does v6.2 M2 also have the issue?

Thanks

Wim

n0cud06 06-19-2012 06:08 PM

Quote:

Originally Posted by Wim (Post 6881)
Which DL software versions does this happen with? Is it just v6.3, or does v6.2 M2 also have the issue?

Thanks

Wim

Thanks for replying Wim. I can't say I have installed v6.2 but I also don't know what version is on the Targus CD. Now I am running latest v6.3 from Displaylink website and still no luck. What is the difference? Isn't 6.3 a new release originally suppose to fix bugs with ATI cards?

Thanks

n0cud06 06-21-2012 11:31 PM

Nothing?
 
hey guys anyone have any idea or the silence just means it can't be fixed? Thanks

Wim 06-29-2012 04:10 PM

I think we have fixed this in our next release for V6.3 M1. Would like to know if you guys find this in v6.2 M2, as I think it was a regression in the v6.3 release.

Wim


All times are GMT. The time now is 01:06 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.