DisplayLink Forum

DisplayLink Forum (https://displaylink.org/forum/index.php)
-   Linux and Open Source (https://displaylink.org/forum/forumdisplay.php?f=29)
-   -   latest updates to Ubuntu 16.04 cause logout on external monitor connection (https://displaylink.org/forum/showthread.php?t=65296)

hinchliff 04-27-2017 04:30 PM

latest updates to Ubuntu 16.04 cause logout on external monitor connection
1 Attachment(s)
I did an apt upgrade today on my Dell XPS13 (9360) running Ubuntu 16.04, and connecting my external displays now causes all sorts of problems.

After a reboot, the first time connecting the displays will cause a logout to occur. After logging back in, subsequent connections of the docking station / external displays does not seem to cause logout.

However, the computer performance is significantly worse than before this Ubuntu upgrade when external monitors are connected, essentially unusable.

The apt upgrade today included a new linux kernel version, 4.4.0-75. I tried using the older kernel (4.4.0-72 ?) when rebooting using the grub menu, but the same problematic behavior persisted even when using the older kernel.

I am currently using DisplayLink version 1.2.1, and I am going to try using the 1.3.52, but I wanted to post this message first.

hinchliff 04-27-2017 04:40 PM

1 Attachment(s)
Same behavior with 1.3.52

micsnare 05-02-2017 05:38 PM

same behavior for me
1 Attachment(s)

I can confirm the very same problem both on 1.2.1 and 1.3.52
It is definitely the docking station (displaylink driver) because when I connect my external monitor through a different adapter (simple usb-c to hdmi adapter) the performance is perfectly fine and normal.
When connected the docking station (Dell D3100) using the display link drivers it's terribly slow, unusable even.

Please find my debug logs attached.

I've even tried downgrading to 1.2.1 but unfortunately it didn't improve the situation.

I'm running a Kubuntu 16.04.2 (kernel: 4.4.0-77) on an Dell XPS 13.

any idea how this could be fixed?

please let me know if you need any other information to troubleshoot this problem.


lerela 05-02-2017 11:09 PM


Exact same issue for me (XPS 9360, Ubuntu 16.04, did an apt upgrade and performance is now terrible).

glxgears is running at 1Hz (unless a part of the window is on the native screen). All the suggested hacks (adding options to /usr/share/X11/xorg.conf.d/20-intel.conf) do not work (I'm not sure how to check whether they are even applied).

My system was working fine and is now barely usable. Can you provide a fix or at least instructions to downgrade? Booting 4.4.0-72 kernel is yielding the same result, as stated by hinchliff.


micsnare 05-14-2017 06:28 PM

any update so far?
is there even a point of uploading our bugreports here? does DisplayLink even take a look?

micsnare 05-16-2017 07:20 PM

@mlukaszek could you please let us know if this is being looked into or not?

All times are GMT. The time now is 07:58 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.