DisplayLink Forum

DisplayLink Forum (https://displaylink.org/forum/index.php)
-   Windows Software (https://displaylink.org/forum/forumdisplay.php?f=28)
-   -   HP 3005pr (https://displaylink.org/forum/showthread.php?t=62705)

cowboy383 03-18-2014 03:12 PM

HP 3005pr
 
1 Attachment(s)
I bought the HP dock when I bought my laptop it came with windows 8. I installed the dock with the software that came with it and every thing has worked fine. I update to windows 8.1 still no problems. I enable Hyper V on the laptop and had been using it since before Thanksgiving but yesterday I disabled HYPER V and I could get the internet to work through the dock so I decided to uninstall and reinstall everything. Bad move the installer for the dock no longer works like it did under windows 8. No biggie will run it under compatibility mode for windows 8. Well it almost worked I got an error "Program Compatibility Assistant" A digitally signed driver required CDC ECM Driver Displaylink Corp. After the install and reboot nothing worked so I removed from add/remove and download the clean up tool, rebooted, and installed the DisplayLink_7.5M1.exe for windows. Every looked liked it went fine asked to reboot so I did. Both of my displays came online, USB's seemed to be functioning looked through the device manager and noticed that I had an exclamation on Displaylink Network Adapter NCM(This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

{Operation Failed}
The requested operation was unsuccessful.)

Went to driver section and clicked on update driver --->Browse my computer for driver software---->Browse----->C:\Program Files\DisplayLink Core Software\CdcNcmDriver\Ndis6.2.Hck81-------->OK

The message (The best driver software for your device is already installed)

I uninstalled the device rebooted same problem.

I went to the folder C:\Program Files\DisplayLink Core Software\CdcNcmDriver\Ndis6.2.Hck81 and right clicked the dlcdcncm6.inf file and clicked install ERROR ----- The system cannot find the file specified. I also deleted dlcdcncm6_x64.sys from C:\Windows\System32\drivers and did the previous step again, it recreated the file dlcdcncm6_x64.sys and also creates a Windows event log message

Log Name: System
Source: Microsoft-Windows-UserPnp
Date: 3/18/2014 9:58:12 AM
Event ID: 20001
Task Category: (7005)
Level: Information
Keywords:
User: SYSTEM
Computer: ME
Description:
Driver Management concluded the process to install driver dlcdcncm6.inf_amd64_dc9d63a853a2fc88\dlcdcncm6.inf for Device Instance ID USB\VID_17E9&PID_430A&MI_05\7&5F57DE3&3&0005 with the following status: 0x2.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Microsoft-Windows-UserPnp" Guid="{96F4A050-7E31-453C-88BE-9634F4E02139}" />
<EventID>20001</EventID>
<Version>0</Version>
<Level>4</Level>
<Task>7005</Task>
<Opcode>0</Opcode>
<Keywords>0x8000000000000000</Keywords>
<TimeCreated SystemTime="2014-03-18T14:58:12.561175900Z" />
<EventRecordID>718399786</EventRecordID>
<Correlation />
<Execution ProcessID="5136" ThreadID="8944" />
<Channel>System</Channel>
<Computer>ME</Computer>
<Security UserID="S-1-5-18" />
</System>
<UserData>
<InstallDeviceID xmlns="http://manifests.microsoft.com/win/2004/08/windows/userpnp">
<DriverName>dlcdcncm6.inf_amd64_dc9d63a853a2fc88\d lcdcncm6.inf</DriverName>
<DriverVersion>7.4.51235.0</DriverVersion>
<DriverProvider>DisplayLink Corp.</DriverProvider>
<DeviceInstanceID>USB\VID_17E9&amp;PID_430A&amp;MI _05\7&amp;5F57DE3&amp;3&amp;0005</DeviceInstanceID>
<SetupClass>{4D36E972-E325-11CE-BFC1-08002BE10318}</SetupClass>
<RebootOption>false</RebootOption>
<UpgradeDevice>true</UpgradeDevice>
<IsDriverOEM>true</IsDriverOEM>
<InstallStatus>0x2</InstallStatus>
<DriverDescription>DisplayLink Network Adapter NCM</DriverDescription>
</InstallDeviceID>
</UserData>
</Event>


Log Name: System
Source: Microsoft-Windows-UserPnp
Date: 3/18/2014 9:58:12 AM
Event ID: 20003
Task Category: (7005)
Level: Information
Keywords:
User: SYSTEM
Computer: ME
Description:
Driver Management has concluded the process to add Service dlcdcncm6_x64 for Device Instance ID USB\VID_17E9&PID_430A&MI_05\7&5F57DE3&3&0005 with the following status: 0.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Microsoft-Windows-UserPnp" Guid="{96F4A050-7E31-453C-88BE-9634F4E02139}" />
<EventID>20003</EventID>
<Version>0</Version>
<Level>4</Level>
<Task>7005</Task>
<Opcode>0</Opcode>
<Keywords>0x8000000000000000</Keywords>
<TimeCreated SystemTime="2014-03-18T14:58:12.529153700Z" />
<EventRecordID>718399785</EventRecordID>
<Correlation />
<Execution ProcessID="5136" ThreadID="8944" />
<Channel>System</Channel>
<Computer>ME</Computer>
<Security UserID="S-1-5-18" />
</System>
<UserData>
<AddServiceID xmlns="http://manifests.microsoft.com/win/2004/08/windows/userpnp">
<ServiceName>dlcdcncm6_x64</ServiceName>
<DriverFileName>\SystemRoot\system32\DRIVERS\dlcdc ncm6_x64.sys</DriverFileName>
<DeviceInstanceID>USB\VID_17E9&amp;PID_430A&amp;MI _05\7&amp;5F57DE3&amp;3&amp;0005</DeviceInstanceID>
<PrimaryService>true</PrimaryService>
<UpdateService>true</UpdateService>
<AddServiceStatus>0</AddServiceStatus>
</AddServiceID>
</UserData>
</Event>


SO this is where I'm at. I've uninstalled, unplugged, rebooted, ran clean up tool, ran CCleaner, but nothing seems to work. Attached is the logs I hope someone help.
Thanks Mike

JamesH 03-24-2014 01:56 PM

Hi,

I'm checking on the install paths at the moment.

In the meantime can you these steps:

Right click on Displaylink Network Adapter in device manager
Select Driver
Select Update Driver
Select Browse my computer for driver software
Select Browse
Enter C:\Program Files\DisplayLink Core Software\
Check Include subfolders
Select Next

Thanks,
James

cowboy383 03-24-2014 02:19 PM

Thanks for the reply

Windows found the driver software for your device but encountered an error while attempting to install it

Displaylink Network Adapter NCN

The system cannot find the file specified.

cowboy383 03-24-2014 02:26 PM

1 Attachment(s)
Attached is the setupapi.dev.log

JamesH 03-25-2014 04:20 PM

Hi

I've raised this internally for further investigation.

Thanks,
James

Szymon 03-26-2014 09:28 AM

Hi,

Reading your setupapi.dev.log I have an impression that Windows file repository in driver store is in somewhat inconsistent state.

To try fixing your network problem I would advice:

1. Unplug the dock
2. From the desktop right click the start button and select "Command Prompt (Admin)"
3. Type: pnputil -f -d oem27.inf
4. Type: pnputil -a C:\Program Files\DisplayLink Core Software\CdcNcmDriver\Ndis6.2.Hck81\dlcdcncm.inf
5. Plug in the dock and see if this helps

NOTE for other viewers of this forum: Do NOT execute "pnputil -f -d oem27.inf" on your machine. The name of the file has been determined by analysing cowboy383 logs and it would only be correct in this particular case. Executing it on other machines may cause uninstallation of other drivers.

Regards,
Szymon

cowboy383 03-26-2014 01:27 PM

Quote:

Originally Posted by Szymon (Post 73847)
Hi,

Reading your setupapi.dev.log I have an impression that Windows file repository in driver store is in somewhat inconsistent state.

To try fixing your network problem I would advice:

1. Unplug the dock
2. From the desktop right click the start button and select "Command Prompt (Admin)"
3. Type: pnputil -f -d oem27.inf
4. Type: pnputil -a C:\Program Files\DisplayLink Core Software\CdcNcmDriver\Ndis6.2.Hck81\dlcdcncm.inf
5. Plug in the dock and see if this helps

NOTE for other viewers of this forum: Do NOT execute "pnputil -f -d oem27.inf" on your machine. The name of the file has been determined by analysing cowboy383 logs and it would only be correct in this particular case. Executing it on other machines may cause uninstallation of other drivers.

Regards,
Szymon

Thanks Szymon

Step 3 complected successfully however step 4 did not i had to change it to
pnputil -a "C:\Program Files\DisplayLink Core Software\CdcNcmDriver\Ndis6.2.Hck81\dlcdcncm6.inf"

After that it stated

Processing inf : dlcdcncm6.inf
Driver package added successfully.
Published name : oem27.inf

Total attempted: 1
Number successfully imported: 1

reconnected dock and powered it on everything comes up but network same exclamation

This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

{Operation Failed}
The requested operation was unsuccessful.

Wim 03-31-2014 02:59 PM

You may have already tried this, but have you tried power cycling the dock to see if this solves the issue?

Wim

Southside 05-12-2016 02:04 PM

1 Attachment(s)
I know this is an old thread but I'm having this same issue with a Lenovo USB3 dock plugged into a Dell Latitude laptop. I have tried uninstalling, using the cleaner and then installing the 7.9 M7 drivers but I still keep getting the error when I try to install the driver that "the system could not find the file specified".

I've attached the results from what the support tool generated. Hopefully somebody can help?

Thanks


All times are GMT. The time now is 09:18 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.