DisplayLink Forum

DisplayLink Forum (https://displaylink.org/forum/index.php)
-   CLOSED: Mac 1.6 Release (https://displaylink.org/forum/forumdisplay.php?f=11)
-   -   1.6 Beta 2 with New i7 MBP screen flashes/flickers (https://displaylink.org/forum/showthread.php?t=301)

frankhsueh 04-24-2010 03:47 PM

1.6 Beta 2 with New i7 MBP screen flashes/flickers
 
I have the new MBP with Core i7 processor running 10.6.3 with all current updates. The displaylinked display would flash/flicker when I open applications like Soundtrack Pro, Quicktime Player 7, Movist, Photoshop CS4 and BOTH the main (MBP screen) display and external displaylinked display would flash/flicker when I quit the application. Any fix?

MCV 04-25-2010 02:33 PM

Nooooooo!!!
 
Damnit! I was just about to update too! I'm glad I read your post before I did. If you get the resolved, please update with the fix. Likewise, if others are running the new MacBook Pro and NOT experiencing this problem, please chime in.

Thanks again.

MCV

MCV 04-26-2010 12:29 AM

Seems OK
 
OK, so I took a chance and gave beta 2 a shot. I've been running it almost all day with no issues whatsoever. If I see anything crazy I'll report back but, fingers crossed, I think everything is fine on my end.

frankhsueh 04-26-2010 02:27 AM

I couldn't find any fix to get the problem resolved. Same symptom happened on 1.5 and 1.6b1 and 1.6b2. That wasn't the case when I had my 1st generation Unibody MBP (5,1).

Carlo 04-26-2010 10:56 AM

Debug info please
 
Hi Frank,

Can you please use the tool at http://www.displaylink.com/support/ask_question.php
And let us have the logs? You can attach them here: http://www.displaylink.com/support/ask_question.php

Are the screens continuously flashing or they flash 'only' when the apps are started and closed? During the flashing is anything else happening (resolution change, windows moving, etc.)?

frankhsueh 04-27-2010 04:25 AM

1 Attachment(s)
Hi Carlo,

I have attached the log. There are total of 3 of them, from 1.5, 1.6b1 and 1.6b2. I've also included a link to youtube on the symptom I have.

http://www.youtube.com/watch?v=qyEqq4BNJ3s

Thanks

Carlo 04-27-2010 09:46 AM

Switching GPU?
 
Thank you so much Frank,

This is a high quality bug report!

It looks like this flash happens when Mac OS is switching GPU. And it's doing so when certain applications are opened, probably because they are linking frameworks that can benefit from the faster GPU.
If this is true this issue should only be visible on the new 15" and 17" MPB.

The symptom is not too bad luckily. The only hint in your logs is a WindowServer error, which is compatible with the fact that you're not seeing any kernel panic. And that the flash is on all screens. We'll start from there. And from getting a new MBP :-)

I have to warn you that we are working on other issues and improvements so I can't commit on a date for a fix.

frankhsueh 04-27-2010 05:09 PM

Hi Carlo,

I did some further testing and found your diagnosis to be correct. If I disable graphics auto switching to make it run on discrete GPU the whole time, the screens will not flash during launching/quitting applications.


All times are GMT. The time now is 09:34 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.