DisplayLink Forum

DisplayLink Forum (https://displaylink.org/forum/index.php)
-   Mac Software (https://displaylink.org/forum/forumdisplay.php?f=30)
-   -   Endless log spam _CGXGLDisplayContextForDisplayDevice: No matching context for device (https://displaylink.org/forum/showthread.php?t=62987)

magillagorilla 05-13-2014 03:41 AM

Endless log spam _CGXGLDisplayContextForDisplayDevice: No matching context for device
 
So I've just put in an Anker USB3 -> HDMI adapter, loaded the latest beta software and it works great.

However my console is now spammed *ENDLESSLY* with

Code:

5/12/14 10:39:21.472 PM WindowServer[295]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fbae3402cd0) - disabling OpenGL
5/12/14 10:39:21.572 PM WindowServer[295]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fbae3402cd0) - disabling OpenGL
5/12/14 10:39:21.680 PM WindowServer[295]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fbae3402cd0) - disabling OpenGL
5/12/14 10:39:21.763 PM WindowServer[295]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fbae3402cd0) - disabling OpenGL
5/12/14 10:39:21.872 PM WindowServer[295]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fbae3402cd0) - disabling OpenGL
5/12/14 10:39:21.963 PM WindowServer[295]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fbae3402cd0) - disabling OpenGL
5/12/14 10:39:22.022 PM WindowServer[295]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fbae3402cd0) - disabling OpenGL
5/12/14 10:39:22.052 PM WindowServer[295]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fbae3402cd0) - disabling OpenGL
5/12/14 10:39:22.164 PM WindowServer[295]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fbae3402cd0) - disabling OpenGL
5/12/14 10:39:22.281 PM WindowServer[295]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fbae3402cd0) - disabling OpenGL
5/12/14 10:39:22.363 PM WindowServer[295]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fbae3402cd0) - disabling OpenGL
5/12/14 10:39:22.464 PM WindowServer[295]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fbae3402cd0) - disabling OpenGL
5/12/14 10:39:22.564 PM WindowServer[295]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fbae3402cd0) - disabling OpenGL
5/12/14 10:39:22.672 PM WindowServer[295]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fbae3402cd0) - disabling OpenGL
5/12/14 10:39:22.752 PM WindowServer[295]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fbae3402cd0) - disabling OpenGL
5/12/14 10:39:22.881 PM WindowServer[295]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fbae3402cd0) - disabling OpenGL
5/12/14 10:39:22.964 PM WindowServer[295]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fbae3402cd0) - disabling OpenGL
5/12/14 10:39:23.022 PM WindowServer[295]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fbae3402cd0) - disabling OpenGL
5/12/14 10:39:23.064 PM WindowServer[295]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fbae3402cd0) - disabling OpenGL

About 12 lines a second, it doesn't stop.

Any suggestions on how to stop?

I'm on 10.9.2

magillagorilla 05-13-2014 11:52 AM

Well, I'm not sure what I did to fix this, but after several reboots and clearing nvpram, the log messages have stopped. (cmd-option-p-r during boot before grey screen)

Hope it stays that way.

MickM 05-15-2014 02:13 PM

So what you have observed is THE primary reason I've been avoiding the 2.2 beta all this time. I have a solid state drive and the last thing I need is a dozen long lines PER SECOND and forever written to a log file. Someone previously said the log files are capped in size so it shouldn't be a problem - but that's beside the point. Yes they are capped in size, but they are still endlessly overwritten as the never ending stream of console output continues (and wearing out my SSD).

I tried your suggestion about zapping the PRAM and it did help! Now the console spew isn't continuous, but comes in big spurts whenever anything in the DisplayLink monitor happens (e.g. moving a window, scrolling in a window, Expose etc.). Fortunately moving the mouse around in the DisplayLink monitor doesn't trigger the console spew. It's a lot better now, but it definitely still needs fixing.

magillagorilla 05-15-2014 02:39 PM

Oh man... I just went back in to check, since you said that and it's still happening. My ASL logs yesterday are about 2gb ARGH!!!

This is completely unacceptable. I assume you don't have this problem with an earlier release? I'm thinking about trying an older driver. I can't do this to my system.

MickM 05-15-2014 02:55 PM

After I zapped the PRAM I installed the latest 2.2 beta and now I only get the spew when stuff happens in the DisplayLink window. There are actually several of the same error messages even when I do things in other non-DisplayLink displays, but at least now it's not continuously, relentlessly flooding the console - now it's just activity based. It's still bad and needs fixing, but it's much better. Who knows, it might all start up again like it did with you - if that happens then I'll be uninstalling 2.2 and going back to 2.1 again (with all of it's awful display jittering that 2.2 seems to have fixed).

The only reason I'm using a DisplayLink solution is because, even after all this time, a lightning hub that's even remotely affordable just doesn't exist :-(.

magillagorilla 05-15-2014 03:14 PM

Well I just cleared my asl logs, and went to 2.1 drivers. So far no logspam. 2.1 drivers so far seem to work just as well as 2.2.

MickM 05-15-2014 03:21 PM

Quote:

Originally Posted by magillagorilla (Post 74428)
Well I just cleared my asl logs, and went to 2.1 drivers. So far no logspam. 2.1 drivers so far seem to work just as well as 2.2.

Using 2.1, try going to www.icloud.com in Safari on your DisplayLink monitor and start doing stuff (scrolling, moving windows, selecting things). If you have iCloud Mail try that as well. You'll see a big difference between 2.1 and 2.1 ...

magillagorilla 05-15-2014 04:09 PM

Quote:

Originally Posted by MickM (Post 74429)
Using 2.1, try going to www.icloud.com in Safari on your DisplayLink monitor and start doing stuff (scrolling, moving windows, selecting things). If you have iCloud Mail try that as well. You'll see a big difference between 2.1 and 2.1 ...

Hmm.. Using Chrome and went to icloud. I don't have mail there, so I can't try that, but it hasn't caused any extra logging.. yet..

I was able to watch a video in VLClan (not fullscreen) on the displaylink monitor without issue.

I'll keep an eye on it if I see a uptake I'll try to correlate it with something.

MickM 05-15-2014 04:54 PM

Doh! I wasn't very clear. You won't get any of this silly console logging in 2.1, but what you will see on your DisplayLink monitor when you use Safari to visit iCloud and iCloud Mail is all kinds of display artifact garbage as you try scrolling in windows etc.

MickM 05-15-2014 07:34 PM

This is interesting. I just sent this email to the developer of CircusPonies Notebook. I'll post his reply if it's relevant.

G'Day Jayson,

So this probably has the makings of developers pointing fingers at each other...

I'm using a DisplayLink monitor (a dongle that has has a DVI output is connected to a USB port on my MacBook Pro and I effectively have another monitor). It obviously needs a driver, and that driver is having some teething problems.

If I put e.g. a Finder window in the DisplayLink monitor then nothing much happens. However, if I put a Notebook window in the DisplayLink monitor and bring that window to the front then I get this continuous steady stream of output appearing in the Console. This only happens if the Notebook window is in the DisplayLink monitor and it's the frontmost window - make any other window the frontmost window and the console output stops. It's almost like an active Notebook window is continuously broadcasting something that's upsetting DisplayLink and/or the WindowServer. A sample of the console output is shown below - any idea what might be causing this?

Regards,

Mick

2014.0515 3:57:09.138 PM WindowServer[97]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fd694804690) - disabling OpenGL
2014.0515 3:57:09.704 PM WindowServer[97]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fd694804690) - disabling OpenGL
2014.0515 3:57:10.264 PM WindowServer[97]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fd694804690) - disabling OpenGL
2014.0515 3:57:10.821 PM WindowServer[97]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fd694804690) - disabling OpenGL
2014.0515 3:57:11.381 PM WindowServer[97]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fd694804690) - disabling OpenGL
2014.0515 3:57:11.948 PM WindowServer[97]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fd694804690) - disabling OpenGL
2014.0515 3:57:12.497 PM WindowServer[97]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fd694804690) - disabling OpenGL
2014.0515 3:57:13.064 PM WindowServer[97]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fd694804690) - disabling OpenGL
2014.0515 3:57:13.620 PM WindowServer[97]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fd694804690) - disabling OpenGL
2014.0515 3:57:14.181 PM WindowServer[97]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fd694804690) - disabling OpenGL
2014.0515 3:57:14.737 PM WindowServer[97]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fd694804690) - disabling OpenGL
2014.0515 3:57:15.303 PM WindowServer[97]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fd694804690) - disabling OpenGL
2014.0515 3:57:15.864 PM WindowServer[97]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fd694804690) - disabling OpenGL
2014.0515 3:57:16.421 PM WindowServer[97]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fd694804690) - disabling OpenGL
2014.0515 3:57:16.981 PM WindowServer[97]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fd694804690) - disabling OpenGL
2014.0515 3:57:17.548 PM WindowServer[97]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fd694804690) - disabling OpenGL
2014.0515 3:57:17.787 PM WindowServer[97]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fd694804690) - disabling OpenGL
2014.0515 3:57:18.065 PM WindowServer[97]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fd694804690) - disabling OpenGL
2014.0515 3:57:18.096 PM WindowServer[97]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fd694804690) - disabling OpenGL


All times are GMT. The time now is 11:23 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.