DisplayLink Forum

DisplayLink Forum (https://displaylink.org/forum/index.php)
-   Windows Software (https://displaylink.org/forum/forumdisplay.php?f=28)
-   -   External display keeps briefly losing connection (https://displaylink.org/forum/showthread.php?t=62086)

cdpinker 10-11-2013 01:35 PM

External display keeps briefly losing connection
 
1 Attachment(s)
I have a Dell XPS 13" Core i5 connected to a Targus USB 3.0 docking station (ACP71EU).

I have an external display connected via the DVI port. A few times an hour, at unpredictable intervals, the external display goes black and the extended desktop switches back to just the normal laptop primary display. This last for no more than a few seconds before the external display re-enables and the extended desktop resumes.

All devices that are connected to the dock lose their connection, including booting me off any calls I am on via my USB wireless headset which is plugged into the dock. It all resumes a few seconds later.

I have the latest drivers from the Dell website for my graphics card, chipset and USB 3.0 controller. I also have the latest DisplayLink drivers, and all Windows Updates are installed.

In addition, the mouse movement is quite jerky, which seems to be worse when the laptop is under heavy load or during boot.

I have tried reverting to a previous system restore point, and have also used the DisplayLink driver removal tool to re-install from scratch, but no joy. It doesn't seem specific to this model of hardware as I tried a different Targus dock which had the same problems.

I've attached the Support Tool logs. Can anyone help me identify the cause of this problem?

Thanks in advance

JamesH 10-13-2013 08:58 PM

Hi,

Unfortunately the key support files entitled DisplayLinkManager... are missing, can you rerun the tool and post the results?

Does this happen on both USB 3.0 ports on the notebook?

Thanks,
James

cdpinker 10-15-2013 03:16 PM

Hi, I've re-run it but it outputs the same files as were in the original attachment....

JamesH 10-20-2013 09:12 PM

Hi,

OK so working with what we do have can you try the following?

* Install the latest Intel USB 3.0 driver:
https://downloadcenter.intel.com/Det...?DwnldID=21129
* Install the latest DisplayLink software:
http://www.displaylink.com/support/downloads.php

Thanks,
James


All times are GMT. The time now is 05:19 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.