View Single Post
Old 07-02-2022, 05:02 PM   #1
michaeltate
Junior Member
 
Join Date: Jul 2022
Posts: 1
Default ASUS PQ321Q no longer works at 4k 60hz on M1Ultra Mac Studio

Hi, I have the ASUS PQ321Q which supported MST on my 2013 MacPro trash can. This particular display was originally recommended in an Apple support forum to work with the 2013 Mac Pros. In MST mode it supported 3840x2160 at 60hz using a DisplayPort to Thunderbolt 2 cable. I recently upgraded to a new M1Ultra Mac Studio and cannot get the ASUS display to work in MST mode anymore. I can only get half the display (1920x2160) to run at 60hz. I've tried every combination of Displayport/HDMI/USB-C combination I can think of but nothing works. I just tried installing SwitchRez but it's not showing me 3840x2160 @60hz as an available resolution. I am not sure if this is a display issue or a driver issue. Would a Displaylink adapter address this problem?

I should add if it helps…someone in a different forum recommended I post my issue here as well. They referenced a similar post regarding a different display but on Windows instead of MacOS. https://displaylink.org/forum/showth...ferrerid=24562

Last edited by michaeltate; 07-02-2022 at 05:19 PM.
michaeltate is offline   Reply With Quote