View Single Post
Old 06-19-2012, 03:51 AM   #1
Junior Member
Join Date: Jun 2012
Posts: 3
Unhappy Sony Vaio Stamina/Speed Mode - atikmpag.sys BSOD

Fist of all I did search and found a thread related to this but looks like it's now close so I apologize for creating a new one. I'm using Windows 7 Professional in case it matters to anyone.

Anyway, I found a way around my issue but thought you guys might be able to help fix it or make my life easier. My Sony Vaio Series S i5 is equipped with two graphic cards, one from intel used under Stamina mode and one from AMD Radeon used under Speed mode.

It has a toggle switch to go back and forth and it has always worked fine in fact I use Intel Widi on a regular basis and it only works under Stamina mode. Anyway, I bought a Targus Superspeed USB 3.0 Dual Video docking station and as soon as I installed the driver I started getting the BSOD when under Speed mode. Basically on speed mode (AMD Radeon 6340M) I get a blue screen "ATIKMPAG.SYS" and I have to hold power button to shut it down its the only way.

Anyway it works fine under Stamina (Intel HD Graphic Family) and I have done everything I could think of to get it working with the AMD Radeon drivers: Updated all drivers, removed drivers and reinstalled including both graphic cards, USB 3.0 controller, Display Link driver, remove AMD CCC, deleted regs etc.. nothing worked.

Luckly after playing with it all night. I found out that when I get the blue screen after switching to Speed mode I have to hold the power button to shutdown then it reboots and I have the option to go on Safe Mode. Well it turns out that when I switch to Stamina it disconnect AMD Graphics hardware and for some reason the Displaylink driver won't allow the computer to anable it after reconnecting the harware. So when you switch back to speed the computer will reconnect the card but for some reason the card is disable. I have to manually re-enable the card in safe mode then reboot the computer. From there everything works fine but its a real hassle when you are doing that multiple times a day.

Last edited by n0cud06; 06-19-2012 at 03:54 AM. Reason: OS
n0cud06 is offline   Reply With Quote