View Single Post
Old 08-07-2020, 11:58 AM   #9
Junior Member
Join Date: Jul 2020
Posts: 2

Originally Posted by KatarzynaKowalczyk View Post

Please make sure that you are not missing the tools necessary for the installation.
You have to run following command prior to installing the newest driver:

sudo apt install build-essential dkms
You can also check the following article:

Please give that a try and let me know if it helped.

Best regards,


i have both packages installed and the driver version 5.3.1 is installed and working properly together with the older kernel 5.3.0-62.
It stopped working with the delivery of the newest ubuntu 18.04 kernel version 5.4.0-42.

I tried again to uninstall der displaylink driver. Reboot with the newest kernel. Install all updates. Ensure that build-essential and dkms is installed and tried again to install the displaylink driver as described in article 1944022-how-to-install-displaylink-software-on-ubuntu-20-0 with the same result.
If i switch back to the older kernel it directly start working again.

It seems to be that the driver is incompatible with the actual ubuntu 18.04 kernel.

StefanF is offline   Reply With Quote