View Single Post
Old 02-08-2018, 08:24 AM   #25
Junior Member
Join Date: Feb 2018
Posts: 2
Thumbs up

Originally Posted by sheafoley View Post
Just updated to 10.13.4 (beta) and my display link has ceased to work.

I have uninstalled and re-installed the latest version.

It seems that my monitor recognizes a signal (as it doesn't go to sleep) but it is not getting picture nor does it show in the 'arrangement' tab for my display preferences.

If anyone has any insight, it would be greatly appreciated.

Did you fix this, I have had the same issue and this fixed it for me...
  • Download 4.1.11 driver, install as normal
  • Reboot MAC and log back in, screens are still not working
  • Go to System Preferences > Security & Privacy
  • At the bottom of the General screen, it will say something like, certain apps were stopped from installing or loading, I can't quite remember exact message
  • Click message and then select the DisplayLink Corp option and it will ask to reboot again.
  • Reboot MAC and then all should be fine

Hope this helps someone!
LawrenceShipman is offline   Reply With Quote