Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Windows Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 05-18-2023, 05:42 PM   #1
ldillon
Junior Member
 
Join Date: May 2023
Posts: 1
Default Dell Latitude 5430 says power adaptor only 19 watts

Greetings,
I have a Dell Latitude 5430 that's displaying an error at boot that says that the attached power adapter is only 19 watts and to plug in a 60 watt power adapter.

It's using the included Chicony 135 watt power adapter. It's also complaining in Windows 11 about battery not charging, and the attached monitors are not detected and Ethernet doesn't work.

I've tried updating the DisplayLink software to 11.0 M0 Jan 23, 2023. No difference.

I've tried swapping out the Docking station, power adapter and USB C cable with a brand new one, right out of the box. No difference.

model: UD-ULTC4K

Wild guess is maybe a Windows or Dell update changed something?
Any ideas?

-Larry

Edit:

Resolved:
We found the issue. The user plugged the laptop into the USB-C on the front, versus the back.

Last edited by ldillon; 05-18-2023 at 08:20 PM. Reason: Issue resolved
ldillon is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.