Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Mac Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 10-02-2023, 09:14 PM   #11
webby
Junior Member
 
Join Date: May 2018
Posts: 2
Default

I updated to Sonoma on my M2 air and no new issues.

I still have an issue where my second (BVU195-usb attached) monitor sometimes doesn't recover from sleep and I have to disconnect/reconnect to make it work.
webby is offline   Reply With Quote
Old 10-02-2023, 10:05 PM   #12
LennyE
Junior Member
 
Join Date: Oct 2023
Posts: 2
Default

After updating to Sonoma I'm experiencing quite noticeable lag, especially when scrolling – and sometimes the momentum scrolling using trackpad or magic mouse straight up doesn't work (scroll is very choppy).

Most problematic though is that if the Displaylink software is closed, it won't ever run again without a complete reinstall (reboot won't fix it). What happens is that if the app is ever closed and then opened after installation, it will without exception instantly crash the moment the USB-C cable from the hub is connected.
LennyE is offline   Reply With Quote
Old 10-03-2023, 10:51 PM   #13
raymaker
Junior Member
 
Join Date: Oct 2023
Posts: 1
Default

I'm experiencing very bad lag on my external monitor with Sonoma on MBA 15'. I'm already on latest Displaylink Manager 1.10.0 Alpha 2 Build 116.

It was much smoother before I upgraded from Ventura to Sonoma a few days ago.
raymaker is offline   Reply With Quote
Old 10-04-2023, 08:32 AM   #14
LennyE
Junior Member
 
Join Date: Oct 2023
Posts: 2
Default

I managed to resolve my problems with lag. No idea if some of the steps below are abundant, but I'm not going to mess with my setup now that it's finally working. This is what I did:
  • Disconnected everything
  • Reverted back to DisplayLink 1.8.1 (since this was 100% working prior to updating MacOS to Sonoma)
  • Connected my 4k monitor (BenQ PD3200u) using both the dock (Ugreen 90912 "Revodok") and directly with a USB-C to HDMI cable.
  • Put HDMI input 1 and 2 side by side on the monitor (picture in picture, a function on this model of monitor), could still observe lag when going through the dock but direct cable was perfectly fine.
  • Toggled on Experimental 3008x and 2560x mode in DisplayLink settings – Suddenly lag ceased to occur –however scaling looked terrible on the monitor (very fuzzy).
  • Couldn't select proper 4K in display settings for the input that was running through the dock (no idea why experimental mode would do this, but whatever), so I used an app called "BetterDisplay" to force 3840 x 2160 – which worked and the display remained lag free at 60hz (max refresh rate for this monitor).

I don't know why this works, or if some steps above can be omitted from the "solution". Perhaps this will help someone else with this frustrating problem, or be useful for fixing the issue outright.

This also probably(?) doesn't solve the issue I had with DisplayLink software crashing after having been exited out of (after initial installation) every time a USB-C connection is detected. This could have been a whole other issue with Sonoma or something entirely different – however I will not push my luck now that this works. The day I have to do that, I'll update in this thread if the problem persists.
LennyE is offline   Reply With Quote
Old 10-04-2023, 11:25 AM   #15
KatarzynaCzaja
DisplayLink Tech Support
 
KatarzynaCzaja's Avatar
 
Join Date: Apr 2020
Posts: 461
Default

Hello,

If you are seeing issues with lags in MacOS Sonoma and you have the latest drivers installed (1.10 Aplha 2) please reach out directly to our support team by sending and email to: technical-enquiries@synaptics.com or you can go through the DisplayLink Manager app and Support tab.

Please also make sure to gather logfiles, link to the tool and instructions is located under the 4th link in my signature.

Last edited by KatarzynaCzaja; 10-04-2023 at 11:38 AM.
KatarzynaCzaja is offline   Reply With Quote
Old 10-04-2023, 03:22 PM   #16
plasticine
Junior Member
 
Join Date: Mar 2023
Posts: 21
Default

Quote:
Originally Posted by KatarzynaCzaja View Post
Hello,

If you are seeing issues with lags in MacOS Sonoma and you have the latest drivers installed (1.10 Aplha 2) please reach out directly to our support team by sending and email to: technical-enquiries@synaptics.com or you can go through the DisplayLink Manager app and Support tab.

Please also make sure to gather logfiles, link to the tool and instructions is located under the 4th link in my signature.
Czész Katarzyna,

for those experiencing that lag, could it be a provisory solution to revert to the 1.9 Since in your website it says is compatible with Sonoma 14 too?
plasticine is offline   Reply With Quote
Old 10-04-2023, 10:56 PM   #17
tlitony
Junior Member
 
Join Date: Oct 2023
Posts: 2
Angry

Quote:
Originally Posted by plasticine View Post
Czész Katarzyna,

for those experiencing that lag, could it be a provisory solution to revert to the 1.9 Since in your website it says is compatible with Sonoma 14 too?
Hey, I am on 1.9, running a M1 MBP, two monitors @ 1080p, 120hz, with Belkin Triple DD. Awful lag when using these two monitors, experiencing the same trackpad frame skipping and general lag when using 1.9. I just upgraded to 1.10 A2, which hopefully fixes this, which seems bleak.

Will return with update. If this does not work, will revert to 1.8.1, as the previous user, @LennyE suggested.
tlitony is offline   Reply With Quote
Old 10-05-2023, 07:01 AM   #18
plasticine
Junior Member
 
Join Date: Mar 2023
Posts: 21
Default

Quote:
Originally Posted by tlitony View Post
Hey, I am on 1.9, running a M1 MBP, two monitors @ 1080p, 120hz, with Belkin Triple DD. Awful lag when using these two monitors, experiencing the same trackpad frame skipping and general lag when using 1.9. I just upgraded to 1.10 A2, which hopefully fixes this, which seems bleak.

Will return with update. If this does not work, will revert to 1.8.1, as the previous user, @LennyE suggested.
Yeah let us know. I have not installed Sonoma yet, but I have the 1.9.1 working fine, so I'm waiting to have more positive feedback
plasticine is offline   Reply With Quote
Old 10-05-2023, 11:34 AM   #19
mmacfanboy
Junior Member
 
Join Date: Oct 2023
Posts: 1
Default Sonoma

I use geforce NOW and since sonoma update the external screen is extremely laggy.
mmacfanboy is offline   Reply With Quote
Old 10-05-2023, 10:47 PM   #20
offbeatmammal
Junior Member
 
Join Date: Oct 2023
Posts: 1
Default

Quote:
Originally Posted by PVJG View Post
I upgraded the other day. Everything seems to work fine except there is an annoying purple screen sharing icon in the menu bar on all screens whenever display link is running.

same issue - looks like it's a macOS feature, but annoyingly no way to say that DisplayLink is allowed to monitor my screen. What makes it extra annoying is that every now and then it flickers and it's just enough to distract me!
Attached Images
File Type: jpg Screenshot 2023-10-06 at 9.38.48 am.jpg (16.0 KB, 0 views)
offbeatmammal is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.