Go Back   DisplayLink Forum > Alpha, Beta Software Testing Programs > Closed Alpha and Beta Programs > CLOSED - 8.1 Alpha for Windows

 
 
Thread Tools Search this Thread Display Modes
Old 11-07-2016, 05:13 PM   #1
jaydub
Junior Member
 
Join Date: Nov 2016
Posts: 6
Default Feedback for 8.1 alpha win 10 x64 prof.

The install/update went ok, there was a long delay (30sec+) after it was done before the screens came back on.

the mouse jitter is better.

the cpu usage by WUDFHost.exe ( Windows Driver Foundation - User-mode Driver Framework Host Process)
is still very high

mem usage sits around 100mb

when sitting idle with no videos or animation on screen, nor using the keyboard or mouse. The WUDFHost.exe process sits at 10-20% CPU usage.

if you move the mouse this will jump up to 45% + (mouse is connected directly to pc not even going through the dock, looks like its the movement on the screen causing this)

have a video playing no kb or mouse use 25-35%

Just typing fast can get it to 18-30%

these are not spikes this is sustained cpu usage if doing any of the above.

dock D3100 3x screens
PC Dell E7470
m.2 SSD
i5-6300 @ 2.4
16gb ram


******* just to follow up got my first random crash of the dock,(3.5 hrs of use) all monitors and connected items froze for 10-15 sec then dock disconnected and came back up with one monitor un-usable(lit up with random colors system did not see it as connected) till I power cycled the dock

Last edited by jaydub; 11-08-2016 at 02:49 PM.
jaydub is offline  
Old 11-08-2016, 02:08 PM   #2
jaydub
Junior Member
 
Join Date: Nov 2016
Posts: 6
Default

I have ran the support tool and attached the zip
Attached Files
File Type: zip MININT-34H3O4P_20161108_080120.zip (870.3 KB, 203 views)
jaydub is offline  
Old 11-08-2016, 02:47 PM   #3
jaydub
Junior Member
 
Join Date: Nov 2016
Posts: 6
Default

dock just crashed the following popped into windows event viewer

A problem has occurred with one or more user-mode drivers and the hosting process has been terminated. This may temporarily interrupt your ability to access the devices.

- System

- Provider

[ Name] Microsoft-Windows-DriverFrameworks-UserMode
[ Guid] {2E35AAEB-857F-4BEB-A418-2E6C0E54D988}

EventID 10110

Version 1

Level 1

Task 64

Opcode 0

Keywords 0x2000000000000000

- TimeCreated

[ SystemTime] 2016-11-08T15:35:02.562147200Z

EventRecordID 7837

Correlation

- Execution

[ ProcessID] 1028
[ ThreadID] 1340

Channel System

Computer XXXXXXXX

- Security

[ UserID] XXXX


- UserData

- UMDFHostProblem

[ lifetime] {BE4EE38B-C8B8-45C5-9907-5E0FFF24A0FE}
- Problem

[ code] 8
[ detectedBy] 2

ExitCode 0

- Operation

[ code] 1879048193
Message 0

Status 4294967295
Followed by this error 5 times.

The device Dell D3100 USB3.0 Dock (location 0000.0014.0000.015.003.000.000.000.000) is offline due to a user-mode driver crash. Windows will attempt to restart the device 5 more times. Please contact the device manufacturer for more information about this problem.
- System

- Provider

[ Name] Microsoft-Windows-DriverFrameworks-UserMode
[ Guid] {2E35AAEB-857F-4BEB-A418-2E6C0E54D988}

EventID 10111

Version 1

Level 1

Task 64

Opcode 0

Keywords 0x2000000000000000

- TimeCreated

[ SystemTime] 2016-11-08T15:35:02.737543300Z

EventRecordID 7838

Correlation

- Execution

[ ProcessID] 1028
[ ThreadID] 1340

Channel System

Computer XXXXXX

- Security

[ UserID] XXXXXX


- UserData

- UmdfDeviceOffline

[ lifetime] {BE4EE38B-C8B8-45C5-9907-5E0FFF24A0FE}
- DeviceInfo

FriendlyName Dell D3100 USB3.0 Dock

Location 0000.0014.0000.015.003.000.000.000.000

InstanceId USB\VID_17E9&PID_436E&MI_00\7&2328A35F&1&0000


RestartCount 5
jaydub is offline  
Old 11-09-2016, 01:11 PM   #4
AlbanRampon
DisplayLink Tech Support
 
AlbanRampon's Avatar
 
Join Date: Sep 2015
Location: Cambridge, UK
Posts: 1,409
Arrow

Hello,

Thank you for trying. The initial 30 second will be addressed in the release.
Would you please be able to use the diagnostic tool again?
It will collect the crash information. The event viewer information doesn't give what tripped, only that it did trip.

I'm suspecting this is what we have observed too and is currently under investigation. Did you get a freeze or a blink?

Kind regards,
Alban
AlbanRampon is offline  
Old 11-09-2016, 02:52 PM   #5
jaydub
Junior Member
 
Join Date: Nov 2016
Posts: 6
Default

I have attached the new .zip.

I am currently back on a standard dell e-port dock due to the issues with the d3100, but the logs should still have the crash info. I can switch back to the d3100 if you need any further testing

for the freeze/hang. the system would make the usb disconnected tone and one of my monitors would blink out mouse, kb and audio would work for another 15ish secs then everything would go black. The screens would flicker on and all open windows would be resized and moved to the main monitor (same as if I had undocked), then i could move everything back and be good for a few hours.

I did have one time that it froze like the above came up, and then crashed only a few minutes later.

This is when i made the move back to the old style dock. Due to needing/wanting to test the new displaylink drivers as they get updated i wanted to keep the alpha ones in place, rather than rolling back for stability but increased slowdown of 8.0
Attached Files
File Type: zip MININT-34H3O4P_20161109_084804.zip (1,015.0 KB, 223 views)

Last edited by jaydub; 11-09-2016 at 03:00 PM.
jaydub is offline  
Old 12-06-2016, 12:41 PM   #6
AlbanRampon
DisplayLink Tech Support
 
AlbanRampon's Avatar
 
Join Date: Sep 2015
Location: Cambridge, UK
Posts: 1,409
Arrow

Hello,

I have posted the 8.1 Release Candidate which addresses the crashes:
Download 8.1_M0_Release_Candidate_8.1.855_Installer.zip

The shutdown being longer has been accepted by Microsoft as a bug: we fixed a bug in our code which made an OS bug visible.
There was not enough time to safely revert our fix for 8.1 M0, so we will reintroduce our bug (!) for 8.1 M1. Windows bug will be fixed in next OS version.

Kind regards,
Alban
AlbanRampon is offline  
Old 12-08-2016, 04:55 PM   #7
SchiefesFenster
Junior Member
 
Join Date: Oct 2016
Posts: 6
Default

Hi Alban,
just installed the 8.1 M0 and boy, what an improvement. No 30sec timeout anymore after installation. The mouse lagging is now completely gone. Let's monitor the glitch outs ...But I'm confident of this version
SchiefesFenster is offline  
Old 12-08-2016, 05:58 PM   #8
AlbanRampon
DisplayLink Tech Support
 
AlbanRampon's Avatar
 
Join Date: Sep 2015
Location: Cambridge, UK
Posts: 1,409
Thumbs up

Quote:
Originally Posted by SchiefesFenster View Post
Hi Alban,
just installed the 8.1 M0 and boy, what an improvement. No 30sec timeout anymore after installation. The mouse lagging is now completely gone. Let's monitor the glitch outs ...But I'm confident of this version
Thank you for taking the time to report on this!
I will feed back to engineering in the morning during our daily stand up. They will be delighted to hear their hard work makes a difference.
Formal release of 8.1 M0 planned for 19th December, unless something wrong is uncovered by our testers or someone else.
Kind regards,
Alban
AlbanRampon is offline  
Old 12-13-2016, 07:19 PM   #9
SchiefesFenster
Junior Member
 
Join Date: Oct 2016
Posts: 6
Default

After some days testing I experienced absolutely no freezes/glitches/blackouts. This version for me seems to be perfect
OK, sometimes when watching Netflix + on another screen watching soccer it lags a bit but that's OK for me. If there is room for improvement, even better.
Thanks so far, brilliant job
SchiefesFenster is offline  
Old 12-14-2016, 05:34 PM   #10
Arnauk
Junior Member
 
Join Date: Dec 2016
Posts: 7
Default

hey guys!

I face the same issue with "Windows Driver Foundation - User-mode Driver Framework Host Process" going up to 40% CPU usage.

if I don't use my mouse or keyboard the cpu usage is 1-2%.

I installed the "8.1_M0_Release_Candidate_8.1.855_Installer", I don't see any improvement.

Unfortunately, I am not as enthusiast as SchiefesFenster !

Good luck for the bug hunt!

Config :
XPS13 9350 with DA200 - 2 x 24 inch screen - one Display Port and one HDMI.
Keyboard USB
Mouse bluetooth MX Master.
Arnauk is offline  
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:49 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.