Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 04-20-2019, 02:22 PM   #1
Joachim Martillo
Junior Member
 
Join Date: May 2016
Posts: 20
Default Ubuntu 19.04 and DisplayLink Driver

Has anyone tried it yet?
Joachim Martillo is offline   Reply With Quote
Old 04-20-2019, 06:45 PM   #2
retrodaredevil
Junior Member
 
Join Date: Jan 2018
Posts: 9
Default

Yeah. After upgrading from 18.04 to 18.10 to 19.04 DisplayLink 4.4 wouldn't work so I tried installing 5.1. While installing, my computer froze except for my mouse. I had to power it off. The first time I powered it off, it was fine. The second time my computer booted into emergency mode. I got out of emergency mode by uninstalling it and rebooting. I believe the reason it's not working is because of how the kernel was upgraded.

If you want to keep a working Displaylink, upgrading probably isn't the best option.

If anyone knows when to expect a working driver for 19.04, some information would be awesome to know.

Last edited by retrodaredevil; 04-21-2019 at 11:14 PM.
retrodaredevil is offline   Reply With Quote
Old 04-22-2019, 12:15 PM   #3
Joachim Martillo
Junior Member
 
Join Date: May 2016
Posts: 20
Default

I just tried to bring up displaylink with 19.04 and did not succeed. I connect my monitor to the laptop through a D1000 -- something that is probably not an issue. I will try again after work.
Joachim Martillo is offline   Reply With Quote
Old 04-22-2019, 10:43 PM   #4
retrodaredevil
Junior Member
 
Join Date: Jan 2018
Posts: 9
Default

So actually, after trying again, it worked. In general, it does seem a little buggy as my plasmashell crashed after rebooting and unlike installs on 18.04 I had to reboot to get the monitors to work at all. I don't really know why it works now. Last time it froze my computer on "Installing EVDI kernel module to kernel tree". This time it did the same thing, but after 10 seconds it completed.

Hopefully there will be a new update released that's tested and actually meant for 19.04, but if you're lucky, 5.1 does work. Sometimes.

Disclaimer: I did run a "sudo apt update && sudo apt dist-upgrade -y" today so it's possible that's the reason it works now.

Last edited by retrodaredevil; 04-22-2019 at 10:49 PM.
retrodaredevil is offline   Reply With Quote
Old 04-23-2019, 09:48 AM   #5
taranovich
Junior Member
 
Join Date: Apr 2019
Posts: 2
Default

5.1 doesn't work for me
taranovich is offline   Reply With Quote
Old 04-24-2019, 07:26 AM   #6
taranovich
Junior Member
 
Join Date: Apr 2019
Posts: 2
Default

guys, you can try to install this driver - https://github.com/AdnanHodzic/displaylink-debian
it works for my 19.04 disco
taranovich is offline   Reply With Quote
Old 04-24-2019, 09:36 AM   #7
ESSEDIA
Junior Member
 
Join Date: Apr 2019
Posts: 4
Unhappy

Ubuntu 18.04.2 LTS and dock Dell D6000... have same problem, more frequent if I use Firefox
ESSEDIA is offline   Reply With Quote
Old 04-25-2019, 09:14 PM   #8
retrodaredevil
Junior Member
 
Join Date: Jan 2018
Posts: 9
Default

When I installed the driver at https://github.com/AdnanHodzic/displaylink-debian I didn't notice any differences from just installing 5.1 by itself.
retrodaredevil is offline   Reply With Quote
Old 04-29-2019, 02:21 PM   #9
ESSEDIA
Junior Member
 
Join Date: Apr 2019
Posts: 4
Default

Using suggest diplaylink-debian I have same problem that official... monitor goes randomly to blank screen and I disconnect and reconnect my D6000...
ESSEDIA is offline   Reply With Quote
Old 05-03-2019, 02:48 PM   #10
EJB
Junior Member
 
Join Date: May 2019
Location: The Netherlands
Posts: 2
Default

On my Ubuntu 19.04 laptop running kernel v5.0.0, is installed v5.1 from GitHub. Right after installing, my second monitor woke up and display its screen. I could use it without an issue. However, after installing it my laptop does not boot anymore. Through CTRL-ALT-F4 I was able to access a shell and remove the driver, after which my laptop booted as usual. SIgh.
EJB is offline   Reply With Quote
Reply

Tags
ubuntu 19.04

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.