Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 02-12-2017, 10:52 AM   #1
happenpappen
Junior Member
 
Join Date: Feb 2017
Posts: 2
Default evdi_mode_valid rejects all modes on kernel 4.9.8

Hi,

when connecting my Lenovo U31-70 to my usb docking station the HDMI connected external display is not recognized and i can see these messages in dmesg:

[ 2986.076049] evdi: [D] evdi_painter_connect:443 (dev=1) Connected with ffff9ac4e7ab3e00
[ 2986.076051] evdi: [D] evdi_detect:75 (dev=1) Painter is connected
[ 2986.076101] evdi: [D] evdi_painter_crtc_state_notify:360 (dev=1) Notifying crtc state: 3
[ 2986.077181] evdi: [D] evdi_detect:75 (dev=1) Painter is connected
[ 2986.077186] evdi: [D] evdi_painter_get_edid_copy:192 (dev=1) 00 ff ff
[ 2986.077223] evdi: [W] evdi_mode_valid:61 Mode 1680x1050@60 rejected
[ 2986.077225] evdi: [W] evdi_mode_valid:61 Mode 1280x1024@60 rejected
[ 2986.077226] evdi: [W] evdi_mode_valid:61 Mode 1280x960@60 rejected
[ 2986.077227] evdi: [W] evdi_mode_valid:61 Mode 1152x864@75 rejected
[ 2986.077228] evdi: [W] evdi_mode_valid:61 Mode 800x600@60 rejected
[ 2986.077229] evdi: [W] evdi_mode_valid:61 Mode 800x600@56 rejected
[ 2986.077230] evdi: [W] evdi_mode_valid:61 Mode 640x480@75 rejected
[ 2986.077231] evdi: [W] evdi_mode_valid:61 Mode 640x480@73 rejected
[ 2986.077233] evdi: [W] evdi_mode_valid:61 Mode 640x480@67 rejected
[ 2986.077234] evdi: [W] evdi_mode_valid:61 Mode 640x480@60 rejected
[ 2986.077235] evdi: [W] evdi_mode_valid:61 Mode 720x400@70 rejected
[ 2986.077236] evdi: [W] evdi_mode_valid:61 Mode 1280x1024@75 rejected
[ 2986.077237] evdi: [W] evdi_mode_valid:61 Mode 1024x768@75 rejected
[ 2986.077238] evdi: [W] evdi_mode_valid:61 Mode 1024x768@70 rejected
[ 2986.077240] evdi: [W] evdi_mode_valid:61 Mode 1024x768@60 rejected
[ 2986.077241] evdi: [W] evdi_mode_valid:61 Mode 832x624@75 rejected
[ 2986.077242] evdi: [W] evdi_mode_valid:61 Mode 800x600@75 rejected
[ 2986.077243] evdi: [W] evdi_mode_valid:61 Mode 800x600@72 rejected
[ 2986.077244] evdi: [W] evdi_mode_valid:61 Mode 848x480@60 rejected

so i think the kernel driver is rejecting all available display modes, so the external display is disabled. Anyone else observing this? All other external devices (mouse, keyboard) are working well.

kind regards,

Christoph
happenpappen is offline   Reply With Quote
Old 02-13-2017, 04:54 PM   #2
demonrik
Junior Member
 
Join Date: Jul 2016
Posts: 2
Default

I have same problem
Was also posted up on evdi github
https://github.com/DisplayLink/evdi/issues/74
FWIW - the workaround does NOT work for me

Is basically a problem with evdi being updated almost a month ago now, but no new Displaylink Manager being released
@mlukaszek mentioned the update is meant to come this month

as it stands I am sticking with kernel 4.8 until the new displaylink manager is released which hopefully fixes this issue.
demonrik is offline   Reply With Quote
Reply

Tags
display issue, kernel 4.9

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:45 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.