Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Mac Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 07-02-2022, 04:02 PM   #1
michaeltate
Junior Member
 
Join Date: Jul 2022
Posts: 1
Default ASUS PQ321Q no longer works at 4k 60hz on M1Ultra Mac Studio

Hi, I have the ASUS PQ321Q which supported MST on my 2013 MacPro trash can. This particular display was originally recommended in an Apple support forum to work with the 2013 Mac Pros. In MST mode it supported 3840x2160 at 60hz using a DisplayPort to Thunderbolt 2 cable. I recently upgraded to a new M1Ultra Mac Studio and cannot get the ASUS display to work in MST mode anymore. I can only get half the display (1920x2160) to run at 60hz. I've tried every combination of Displayport/HDMI/USB-C combination I can think of but nothing works. I just tried installing SwitchRez but it's not showing me 3840x2160 @60hz as an available resolution. I am not sure if this is a display issue or a driver issue. Would a Displaylink adapter address this problem?

I should add if it helps…someone in a different forum recommended I post my issue here as well. They referenced a similar post regarding a different display but on Windows instead of MacOS. https://displaylink.org/forum/showth...ferrerid=24562

Last edited by michaeltate; 07-02-2022 at 04:19 PM.
michaeltate is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:26 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.