Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Windows Software

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 10-02-2023, 10:05 AM   #1
Richard0312
Junior Member
 
Join Date: Oct 2023
Posts: 4
Default Docking station repeatedly losing connection

My docking station seems to keep losing connection to my laptop - I have two external monitors connected to it along with a wired Microsoft keyboard and a basic webcam plus an ethernet cable and nothing else. My external screens go blank and it reverts to just the laptop screen, losing network connectivity along the way. No matter what I try, this just keeps happening. This lasts a few seconds, then everything reconnects and is restored but it interrupts phone calls and online meetings. So far I've tried:

- A new cable between the docking station and the laptop
- The new cable plugged into a different USB port
- Running Windows updates
- Running driver updates (I had the latest ones installed)
- Repowering both the docking station and laptop
- Disabling Wi-Fi adaptor
- Uninstalling the docking station through Device Manager
- Running the Displaylink diagnostic tool and emailing the results to Displaylink. Still haven't heard anything back after over a week

The model is U3DUALHDMIDOCKUK. Getting to the point of binning this and buying a different make. My laptop has only ever run Win11 and this has only started happening in the last few weeks. Current version is 11 Enterprise 22H2. Any thoughts?

Last edited by Richard0312; 10-02-2023 at 12:14 PM.
Richard0312 is offline   Reply With Quote
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.