Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Mac Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-13-2018, 01:46 PM   #1
Lantaalex
Junior Member
 
Join Date: Dec 2018
Posts: 1
Default DL and Java issues

Anyone having issues with java and DL?
Got a 2017MBP/10.14.2 and Just upgraded to 5.0 and having issues with java windows - they are not showing on my monitors
Lantaalex is offline   Reply With Quote
Old 01-03-2019, 09:00 PM   #2
jl640k
Junior Member
 
Join Date: Sep 2018
Posts: 4
Default

Oh wow, I thought I was losing my mind. Yes, I'm seeing this. I'm currently disconnected from my external monitors and tried running some Java apps, and now they work! When connected to the external displays they would just hang, showing that little Java window in the Dock, and the only way to kill them was to 'Force Quit'.

[2018 MBP 15", 10.14.2, DL 5.0.1).
jl640k is offline   Reply With Quote
Old 01-04-2019, 08:13 AM   #3
jl640k
Junior Member
 
Join Date: Sep 2018
Posts: 4
Default

Looks like this bug appeared in 4.3 beta 6:

https://www.displaylink.org/forum/sh...ad.php?t=66114
jl640k is offline   Reply With Quote
Old 01-04-2019, 08:45 AM   #4
jl640k
Junior Member
 
Join Date: Sep 2018
Posts: 4
Default

Java apps seem to work OK with the DL displays connected if I keep the MBP lid open.
jl640k is offline   Reply With Quote
Old 02-20-2019, 07:27 AM   #5
alex.andersen
Junior Member
 
Join Date: Feb 2019
Posts: 2
Default

Java applications work if the built-in display is set as primary, causing the windows to appear on it first. If a DisplayLink monitor is configured as primary the Java application simply dies upon launch. After updating to driver 5.1 (macOS Mojave) the screen briefly flashes black when the Java Application dies.

The easiest way to reproduce this is attempting to open the Java Control Panel through System Preferences.
alex.andersen is offline   Reply With Quote
Old 03-03-2019, 06:31 PM   #6
yash4
Junior Member
 
Join Date: Mar 2019
Posts: 1
Default

The beta version is full of bugs.
yash4 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.