Go Back   DisplayLink Forum > Alpha, Beta Software Testing Programs > Closed Alpha and Beta Programs > CLOSED: 5.2 Software Release

 
 
Thread Tools Search this Thread Display Modes
Old 10-15-2009, 07:36 AM   #21
freitasm
Junior Member
 
Join Date: Oct 2009
Posts: 5
Default

Yes, same here:

HP dv6 with ATI Mobility Radeon HD4650 1GB dedicated video memory.

It all works ok, but if I try running anything graphics intensive - a game for example such as Left 4 Dead then the frame rate drops considerably. Uninstalled the 5.2 RC driver and it's all back to normal.
freitasm is offline  
Old 10-17-2009, 05:04 PM   #22
Martin
Member
 
Join Date: Sep 2009
Posts: 75
Default

Hi guys,


Sorry, I was away and then realised I hadn't subscribed to the thread. Anyway, end of excuses....

But another apology, for the delay in getting the fix to you guys! Our 5.2 product release is due out in a matter of days and that contains my fix (from 1st September!!) for this problem.

Best regards,
Martin.

Last edited by Martin; 10-17-2009 at 05:06 PM.
Martin is offline  
Old 10-17-2009, 06:29 PM   #23
Gamer
Junior Member
 
Join Date: Oct 2009
Posts: 12
Thumbs down

I couldn't care less anymore, my U70 is already on its way back to the dealer. But my system remains messed up from your crappy drivers - I cannot uninstall them even after hours of trying everything, and I still cannot watch videos anymore, nothing but flashing screen! I wonder how this affects the lifespan of the backlighting...

I tried installing the drivers on a completely different machine (ATI onboard graphics) - watching videos (we always talk about main screen here) worked there. But also here it was simply impossible to uninstall the drivers! This really proves it is not a configuration problem, it's simply incredibly bad programming.

I haven't experienced something like this since W98 - a driver that is obviously programmed in a way that it can never be removed again, a driver that might prevent your main video card from being recognised, and that disables video playback on your system, and that survives even system restore! And I really have lots and lots of devices, also exotic ones, believe me.

Using DisplayLink is a nightmare, I'll never touch it again. Thanks for all the wasted time.

An appropriate review (or better call it a "warning") will show up on Amazon soon.
Gamer is offline  
Old 10-17-2009, 08:53 PM   #24
rys
Junior Member
 
Join Date: Oct 2009
Posts: 7
Default

Quote:
Originally Posted by Gamer View Post
I couldn't care less anymore, my U70 is already on its way back to the dealer. But my system remains messed up from your crappy drivers - I cannot uninstall them even after hours of trying everything, and I still cannot watch videos anymore, nothing but flashing screen! I wonder how this affects the lifespan of the backlighting...

I tried installing the drivers on a completely different machine (ATI onboard graphics) - watching videos (we always talk about main screen here) worked there. But also here it was simply impossible to uninstall the drivers! This really proves it is not a configuration problem, it's simply incredibly bad programming.

I haven't experienced something like this since W98 - a driver that is obviously programmed in a way that it can never be removed again, a driver that might prevent your main video card from being recognised, and that disables video playback on your system, and that survives even system restore! And I really have lots and lots of devices, also exotic ones, believe me.

Using DisplayLink is a nightmare, I'll never touch it again. Thanks for all the wasted time.

An appropriate review (or better call it a "warning") will show up on Amazon soon.
Hi,

Had the same problem as you. You have to remove both DisplayLink Graphics and DisplayLink Core under Control Panel->Programs and Features.
rys is offline  
Old 10-18-2009, 01:04 AM   #25
Gamer
Junior Member
 
Join Date: Oct 2009
Posts: 12
Angry

Quote:
Originally Posted by rys View Post
Hi,

Had the same problem as you. You have to remove both DisplayLink Graphics and DisplayLink Core under Control Panel->Programs and Features.
You think I did not try this in the 10+ hours I wasted day & night? Sorry, it's not your fault, but I'm really, really pissed...

DisplayLink Core is what cannot be uninstalled on either machine ("Still in use...", "Severe error..." even if everything else was removed - or seemed to be removed - there are still 3 additional monitors in Device Manager - try removing those and lose access to your video card!!). Two machines, totally different configurations, same error. This is just plain bad programming. Probably some hacks the customer has to pay the price for.

The only reason I'm still writing here is to help others to avoid this nightmare. As I said, I already returned the unit and will definitely never touch this so-called "technology" again.

Look at the FAQ... It states "There are some other solutions which are all inferior to DisplayLink..." Such arrogance really drives me mad.
Gamer is offline  
Old 10-18-2009, 07:29 AM   #26
rys
Junior Member
 
Join Date: Oct 2009
Posts: 7
Default

In fairness, the available software *IS* a beta.

I did not have any trouble uninstalling it (on Windows 7.)

Also, you can slam the U70 on your reviews, but remember that, again, you're using beta software, and second, that the DisplayLink USB video adapter drivers cover much more than just your Samsung U70 product.
rys is offline  
Old 10-18-2009, 01:38 PM   #27
Gamer
Junior Member
 
Join Date: Oct 2009
Posts: 12
Lightbulb

Quote:
Originally Posted by rys View Post
In fairness, the available software *IS* a beta.
You mean 4.6 - which came on the Samsung cd, see my other thread - is beta...? Calling it beta would be exaggerated, it's more like a pre-alpha for internal testing - but declared "suitable for end user deployment" in the release notes...
Gamer is offline  
Old 10-18-2009, 10:26 PM   #28
freitasm
Junior Member
 
Join Date: Oct 2009
Posts: 5
Default

The documentation I got says it's not compatible with Windows 7. You read the documentation, right?

I did install the 5.2 RC on Windows 7 RTM and after finding it slowed down graphics I had no problems uninstalling it.
freitasm is offline  
Old 10-19-2009, 12:41 AM   #29
Gamer
Junior Member
 
Join Date: Oct 2009
Posts: 12
Lightbulb

Quote:
Originally Posted by freitasm View Post
The documentation I got says it's not compatible with Windows 7. You read the documentation, right?
I'm on XP. You read the threads you post in, right?
Gamer is offline  
Old 10-19-2009, 12:42 AM   #30
freitasm
Junior Member
 
Join Date: Oct 2009
Posts: 5
Default

Quote:
Originally Posted by Gamer View Post
I'm on XP. You read the threads you post in, right?
/me go back to the corner in shame...
freitasm is offline  
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.