Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Mac Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 04-04-2014, 07:37 AM   #21
cfenollosa
Junior Member
 
Join Date: Mar 2014
Posts: 9
Default

I will definitely try that Carlo.

In a few days I'll allocate some time to run tasks that usually crash WindowServer for me and send some logs.

Thanks
cfenollosa is offline   Reply With Quote
Old 04-08-2014, 06:40 AM   #22
cfenollosa
Junior Member
 
Join Date: Mar 2014
Posts: 9
Default

Carlo,

I am unable to submit the report. The bug report webpage drops this error: https://www.dropbox.com/s/3d2b2lgwu2...base_error.txt and doesn't allow me to submit it. Please fix it. I'm trying to be as helpful as possible but this is annoying as hell. At least I know you read the forums and can contact you here, thanks for that.

This is the text of the bug report:

Version 2.1 (51922)

Hi

I'm having the following issues only on the external monitor handled by the displaylink adaptor (I have another monitor connected by a displayport to vga adaptor which doesn't suffer these issues)

-The apple menu icon doesn't appear, though the menu works (see video)
-No miniatures, or scrambled miniatures on mission control (see other video)
-Choppy fullscreen video with screen flickering
-Random windowserver crash when activating mission control.
This happens about 5% of the times, which means that if I use mission control, the mac will crash once every 2-3 days. my thoughts about that is that it is a memory leak, because the issue seems to happen when the mac has been running for a long time, and never near after boot.

The windowserver crash happened me once while watching a youtube video, but I haven't been able to reproduce it. the crash log I send you happened when I activated mission control.

Please contact me if you need further information

thanks
Carlos


Bug report file: https://www.dropbox.com/s/6511dx5btpgsijl/Archive.zip
cfenollosa is offline   Reply With Quote
Old 04-09-2014, 01:04 PM   #23
Carlo
Mac Team
 
Carlo's Avatar
 
Join Date: Feb 2009
Posts: 606
Default

Thank you we'll look at them now. The issue in the form has just been fixed... thank you again.

Carlo
Carlo is offline   Reply With Quote
Old 04-11-2014, 03:23 PM   #24
ChristianP
Senior Member
 
ChristianP's Avatar
 
Join Date: Apr 2011
Posts: 279
Default

Could you please post the WindowServer crash logs on 10.9.2 again? The dropbox link is no more valid. The WindowServer crash logs are located in /Library/Logs/DiagnosticReports/. Thanks
ChristianP is offline   Reply With Quote
Old 04-12-2014, 02:28 PM   #25
cfenollosa
Junior Member
 
Join Date: Mar 2014
Posts: 9
Default

ChristianP, are you referring to my logs? I sent you an updated version here: https://www.dropbox.com/s/6511dx5btpgsijl/Archive.zip

If you still want to access the old log, I restored the file: https://www.dropbox.com/s/jfnr37xd61...ndowserver.txt

cheers
Carlos
cfenollosa is offline   Reply With Quote
Old 04-14-2014, 01:04 PM   #26
ChristianP
Senior Member
 
ChristianP's Avatar
 
Join Date: Apr 2011
Posts: 279
Default

Thanks Carlos, the old log you restored is OK and it seems containing the info we need.
ChristianP is offline   Reply With Quote
Old 05-06-2014, 09:13 AM   #27
ChristianP
Senior Member
 
ChristianP's Avatar
 
Join Date: Apr 2011
Posts: 279
Default

Hi Carlos,
we think that the crash you experience is caused by an Apple bug. There are several similar bugs in Mavericks with the WindowServer process crashing during fullscreen transitions.
Since your bug seems machine specific and not easy to reproduce on different machines, the best option would be for you to open a bug with Apple.
You can connect to https://bugreport.apple.com and submit a bug report, including your system profile and your WindowServer crash logs. Please send us the bug ID, when done, so we can follow up with Apple directly and find out if it really was our issue and in case which issue so we can actually do something about it.
Thanks
ChristianP is offline   Reply With Quote
Old 05-06-2014, 05:04 PM   #28
MickM
Member
 
Join Date: Oct 2011
Posts: 52
Default

I've been experiencing this same bug for ages as well. I have a hot corner for Show Desktop and every now and then when my mouse hits that corner the window server crashes and I'm logged out. Super annoying.

I reported it as a bug to Apple back in January (although at the time I didn't know DisplayLink was involved).
MickM is offline   Reply With Quote
Old 05-08-2014, 06:42 AM   #29
cfenollosa
Junior Member
 
Join Date: Mar 2014
Posts: 9
Default

Hi ChristianP,

I submitted the bug to Apple. Here it is: #16850534

Thanks for your help. I hope to have this resolved soon because this may be the first time I'm suffering a random crash using a mac since 2007 and it's making it unusable. I can't gamble on the system crashing while I'm doing work.

cheers,
Carlos
cfenollosa is offline   Reply With Quote
Old 05-09-2014, 06:51 AM   #30
cfenollosa
Junior Member
 
Join Date: Mar 2014
Posts: 9
Default

Apple determined that the bug is a duplicate of #14201901
cfenollosa is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.