Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Mac Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-07-2013, 11:54 PM   #1
ehendrix
Member
 
Join Date: Aug 2011
Posts: 39
Default Show Desktop in Mavericks (10.9)

On Mavericks (10.9) with 1 DisplayLink display attached using 2.1 driver. When doing "show desktop" (thus moving all the windows out of the way) crashes WindowServer.
Attached are 2 crash logs.
ehendrix is offline   Reply With Quote
Old 11-11-2013, 11:13 PM   #2
ehendrix
Member
 
Join Date: Aug 2011
Posts: 39
Default

I had opened a bug report with Apple on this ... just got a reply that this is not an Apple issue but a third-party vendor issue (DisplayLink).
Would thus like someone from DisplayLink to look at this and report.
ehendrix is offline   Reply With Quote
Old 11-18-2013, 09:27 PM   #3
advntstrfe
Junior Member
 
Join Date: Nov 2013
Posts: 2
Default

Would someone please look into this problem as I am having a similar experience (crashes and reverts to login screen every time I attempt to Show Desktop and intermittently when attempting to use Mission Control).
advntstrfe is offline   Reply With Quote
Old 12-09-2013, 05:26 PM   #4
ehendrix
Member
 
Join Date: Aug 2011
Posts: 39
Default

Bump as this is a definite issue and does not seem that Apple is recognizing it as being on their end.
ehendrix is offline   Reply With Quote
Old 12-11-2013, 03:16 AM   #5
advntstrfe
Junior Member
 
Join Date: Nov 2013
Posts: 2
Default

Agreed. This continues to occur sporadically throughout. It is frustrating not being able to use Show Desktop.
advntstrfe is offline   Reply With Quote
Old 12-11-2013, 08:55 PM   #6
itadmincrbc
Member
 
Join Date: Oct 2013
Posts: 55
Default

Apple will say it's DisplayLink and DisplayLink will say it's apple. It's called passing the buck back and forth. Everyone knows Apple doesn't want you connecting non Apple devices to their hardware LOL.
itadmincrbc is offline   Reply With Quote
Old 12-11-2013, 09:58 PM   #7
ehendrix
Member
 
Join Date: Aug 2011
Posts: 39
Default

Understood, but would be nice for someone from DisplayLink to at least acknowledge the issue exist and that they are looking into it as well.
I opened the report with Apple and they at least responded back, have not heard anything from Displaylink.
ehendrix is offline   Reply With Quote
Old 12-17-2013, 03:01 PM   #8
ehendrix
Member
 
Join Date: Aug 2011
Posts: 39
Default

Just updated to 10.9.1 and tried the "Show desktop" again, did it 3-4 times and no crashes. Before it crashed each and every time I tried. So look like Apple fixed this bug even although they responded that it is not on their end.
ehendrix is offline   Reply With Quote
Old 12-18-2013, 11:20 AM   #9
Carlo
Mac Team
 
Carlo's Avatar
 
Join Date: Feb 2009
Posts: 606
Default

We have found different WS crashes in our tests so far in 10.9.1 compared to 10.9. It must be a timings issue that is triggered by different use cases on different setups.

Thank you for posting the update!

Carlo
Carlo is offline   Reply With Quote
Old 01-13-2014, 08:56 PM   #10
ehendrix
Member
 
Join Date: Aug 2011
Posts: 39
Default

Carlo,

So are these items DisplayLink can/needs to address in the driver?
ehendrix is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:12 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.