Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Mac Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 03-23-2014, 03:48 AM   #1
RPD
Junior Member
 
Join Date: Mar 2014
Posts: 9
Exclamation OSX10.9.2 + DL2.2 Beta + Belkin B2B044 == KABOOM

Ever since receiving this Belkin dock, my system began hanging or crashing after the my MBP goes to sleep for the night.

When I try waking it, the system hangs with only the mouse cursor moving or doesn't do anything. I tried isolating it to a specific application when I noticed that unplugging the dock prior to letting the system sleep overnight prevents the system from hanging/crashing. Pretty annoying and defeats the purpose of the dock, but it's a workaround.

My setup:
MBP mDP -> 27" monitor DP
MBP usb 3 -> Belkin Dock
Belkin Dock -> USB Keyboard, LAN, DVI-D -> HDMI 24" monitor

I also noticed that I get the following logs appears in Console.app 1-5 times a second:
2014-03-23 12:42:33.764 AM WindowServer[224]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7fc2c051b9b0) - disabling OpenGL
Does this have to do with the hangs/crashes?

Thanks,
RPD

Last edited by RPD; 03-23-2014 at 03:50 AM.
RPD is offline   Reply With Quote
Old 03-24-2014, 09:08 AM   #2
ChristianP
Senior Member
 
ChristianP's Avatar
 
Join Date: Apr 2011
Posts: 279
Default

_CGXGLDisplayContextForDisplayDevice logs should not be related to the issue you reported. These are WindowServer warnings in disabling OpenGL since it's not supported.

With crashing, do you mean kernel panics? In case, could you please upload the panic logs. You should see Kernel_xx.panic logs in/Library/Logs/DiagnosticReports/.
Any other crash log in that folder generated right before or after the machine crash/hang.
Could you also please use the debug tool ( http://www.displaylink.com/support/ticket.php?id=269) and collect the DisplayLink logs?.

Have you ever used the 2.1 driver with 10.9.2 and experienced a similar problem? In case you've never used it, could you please use it and check if it show the same problem.
Many thanks
ChristianP is offline   Reply With Quote
Old 03-29-2014, 12:44 AM   #3
RPD
Junior Member
 
Join Date: Mar 2014
Posts: 9
Default

Quote:
Originally Posted by ChristianP View Post
_CGXGLDisplayContextForDisplayDevice logs should not be related to the issue you reported. These are WindowServer warnings in disabling OpenGL since it's not supported.

With crashing, do you mean kernel panics? In case, could you please upload the panic logs. You should see Kernel_xx.panic logs in/Library/Logs/DiagnosticReports/.
Any other crash log in that folder generated right before or after the machine crash/hang.
Could you also please use the debug tool ( http://www.displaylink.com/support/ticket.php?id=269) and collect the DisplayLink logs?.

Have you ever used the 2.1 driver with 10.9.2 and experienced a similar problem? In case you've never used it, could you please use it and check if it show the same problem.
Many thanks
Hi Christian,

From the period of Mar 20 to today I have about 110 DisplayLinkUserAgent_*.crash logs. I've attached a couple of these crash logs (CrashLogs.zip) and the logs from running the debug tool (DisplayLinkLogs.zip). I've downgraded the driver from 2.2 to 2.1. I'll post back what happens. Let me know if you need me to try anything else.

Thanks for your help!

RPD
Attached Files
File Type: zip CrashLogs.zip (23.4 KB, 3 views)
File Type: zip DisplayLinkLogs.zip (638.7 KB, 1 views)
RPD is offline   Reply With Quote
Old 04-04-2014, 01:36 AM   #4
RPD
Junior Member
 
Join Date: Mar 2014
Posts: 9
Default



Hi Christian, any update on this issue?
RPD is offline   Reply With Quote
Old 04-09-2014, 02:23 PM   #5
ChristianP
Senior Member
 
ChristianP's Avatar
 
Join Date: Apr 2011
Posts: 279
Default

Quote:
Originally Posted by RPD View Post


Hi Christian, any update on this issue?
Please check your private messages, there are further instructions. Thanks
ChristianP is offline   Reply With Quote
Old 04-23-2014, 02:12 AM   #6
RPD
Junior Member
 
Join Date: Mar 2014
Posts: 9
Default

Quote:
Originally Posted by ChristianP View Post
Please check your private messages, there are further instructions. Thanks
Hi Christian,

I'm still experiencing the crashes. I've ran the log tool and I've included the logs for your review. In addition, my dock is now having the monitor go in and out of power save mode and never fully turning off.

RPD
Attached Files
File Type: zip Displaylink Logs.zip (875.5 KB, 3 views)
RPD is offline   Reply With Quote
Old 04-23-2014, 09:28 AM   #7
ChristianP
Senior Member
 
ChristianP's Avatar
 
Join Date: Apr 2011
Posts: 279
Default

Quote:
Originally Posted by RPD View Post
Hi Christian,

I'm still experiencing the crashes. I've ran the log tool and I've included the logs for your review. In addition, my dock is now having the monitor go in and out of power save mode and never fully turning off.

RPD
Thanks for your feedback and the new logs.
I see some kernel panic logs reported in your system profile. Are you experiencing kernel panics or simply DisplayLinkUserAgent crashes? In case you just see DisplayLinkUserAgent crashes, could you please upload a couple of new DisplayLinkUserAgent crash logs? These are not included in logs collected by the debug tool, but you can find them under yourhomedirectory/Library/Logs/DiagnosticReports/

Thanks
ChristianP is offline   Reply With Quote
Old 04-30-2014, 03:35 PM   #8
RPD
Junior Member
 
Join Date: Mar 2014
Posts: 9
Default

Quote:
Originally Posted by ChristianP View Post
Thanks for your feedback and the new logs.
I see some kernel panic logs reported in your system profile. Are you experiencing kernel panics or simply DisplayLinkUserAgent crashes? In case you just see DisplayLinkUserAgent crashes, could you please upload a couple of new DisplayLinkUserAgent crash logs? These are not included in logs collected by the debug tool, but you can find them under yourhomedirectory/Library/Logs/DiagnosticReports/

Thanks
Hi Christian,

I don't have any logs being generated in that folder. Is there anything you'd like me to try out in the meantime?

RPD
RPD is offline   Reply With Quote
Old 05-05-2014, 04:21 PM   #9
ChristianP
Senior Member
 
ChristianP's Avatar
 
Join Date: Apr 2011
Posts: 279
Default

Ok, so it seems that DisplayLinkUserAgent is not crashing anymore.
Just to be sure, what kind of crash do you experience? Are you experiencing kernel panics? I mean, do you see gray screen and the machine need to be restarted? Thanks
ChristianP is offline   Reply With Quote
Old 05-07-2014, 05:01 AM   #10
RPD
Junior Member
 
Join Date: Mar 2014
Posts: 9
Default

During the course of the day while I'm actively using the system, the system does not have a kernal panic. When I'm away for an extended period of time I often see the displays going grey and restarting the system. Once I log back in I get a 'system had restarted due to an error' message and it is something that involves the DisplayLink.

If the log utility doesn't provide you with that log i can copy it so you can examine the stack trace.

RPD
RPD is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.