Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Windows Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 06-10-2016, 07:52 AM   #1
Ed McD
Junior Member
 
Join Date: Jun 2016
Posts: 7
Unhappy Toshi Dynadock 4K Install Failing

My new Dynadock 4k (model number PA 5217U-1PRP) is intended to work with a new Toshi Satellite S70 laptop running Windows 10. From the Toshiba web site drivers list for the 4K I first tried DisplayLink dynadock and USB Monitor driver V7.9 M3 for Windows 7, 8x, and 10, Posted Date: 2015-10-26 | Version: 7.9.703.0. Install seemed to complete and finish. But no icon appeared in my tray, including in the hidden icons; and there's no reference to DisplayLink at all in my "Apps" list.

I uninstalled the program and used DisplayLink's "cleaner," with a re-start. I then tried DisplayLink Corporate Installer for Windows 7, 8x, and 10
Posted Date: 2015-11-09 | Version: 7.9.664.0. Install seemed to complete and finish - but still no icon or reference to the existence of the software.

I tried Toshiba support, and they gave me web links, one of which led me to an invitation to download Driver Detective to help determine what driver I really need. It won't do anything unless I pay to buy the software - which I won't do. The other link brought me here.

Have I bought a docking station that simply has no available drivers, or does it just not work with my laptop? I'm stymied at the moment.
Ed McD is offline   Reply With Quote
Old 06-10-2016, 11:45 AM   #2
AlbanRampon
Senior Member
 
AlbanRampon's Avatar
 
Join Date: Sep 2015
Location: Cambridge, UK
Posts: 1,629
Default

Hello Ed,

Would you please be able to provide the zip generated by our support tool?
There is a link in my signature explaining how to create it.

From that, I will be able to see the status of the installation and where the issue might be.

Kind regards,
Alban
__________________
Alban Rampon
Senior product manager, universal docking stations and accessories
"DisplayLink is proud to be a Synaptics brand."

Where to download the latest DisplayLink drivers
How to clean up a corrupted installation
How to report issues to DisplayLink for a speedy resolution
AlbanRampon is offline   Reply With Quote
Old 06-10-2016, 05:46 PM   #3
Ed McD
Junior Member
 
Join Date: Jun 2016
Posts: 7
Default

Here's one of the zip links:

http://cdgenp01.csd.toshiba.com/cont...te_Install.zip

Here's the other link that's a direct executable:

http://cdgenp01.csd.toshiba.com/cont...s_with_SLA.exe

Ed
Ed McD is offline   Reply With Quote
Old 06-10-2016, 05:53 PM   #4
Ed McD
Junior Member
 
Join Date: Jun 2016
Posts: 7
Default

I replied with links, but didn't follow your instructions. I'm running the support tool and will send you the results shortly.
Ed McD is offline   Reply With Quote
Old 06-10-2016, 06:12 PM   #5
Ed McD
Junior Member
 
Join Date: Jun 2016
Posts: 7
Default Dynadock 4K DisplayLink Support Tool Result - Zip File

Here's the zip file generated by the Support Tool.

Ed
Attached Files
File Type: zip LAPTOP-LVCVE267_20160610_115043.zip (1.32 MB, 3 views)
Ed McD is offline   Reply With Quote
Old 06-13-2016, 09:44 AM   #6
AlbanRampon
Senior Member
 
AlbanRampon's Avatar
 
Join Date: Sep 2015
Location: Cambridge, UK
Posts: 1,629
Default

Hello Ed,
You cannot have WU and corporate install together as the driver store is locked by WU and the coinstaller tries to update the files in the driver store.
You have files 7.9 M5 (7.9.1488) and 7.9 M7 (7.9.1589) installed but no file from 7.9.703 or 7.9.664.
7.9 M5 & 7.9 M7 being on WU, your computer got updated, damaging your installation.
I wouldn't advise installing our corporate deployment driver on a single computer manually, unless it is to try the process.

The best is now to clean up the mess and start clean.
1. Disconnect the hardware using DisplayLink technology
2. Remove all you installed.
3. Reboot.
4. Use our End User Cleaner (see forum signature), running it specifically with "Run as admin...", even if your user is an admin.
5. Reboot.
6. Install 7.9 M7 and connect the dock when asked.
7. Reboot.
8. If the issue persists, please send new logs.

Reboots are unfortunately necessary because of the kernel (low level) mode drivers which can't be modified whilst Windows run.

Kind regards,
Alban
__________________
Alban Rampon
Senior product manager, universal docking stations and accessories
"DisplayLink is proud to be a Synaptics brand."

Where to download the latest DisplayLink drivers
How to clean up a corrupted installation
How to report issues to DisplayLink for a speedy resolution
AlbanRampon is offline   Reply With Quote
Old 06-14-2016, 01:38 AM   #7
Ed McD
Junior Member
 
Join Date: Jun 2016
Posts: 7
Default

Thanks, Alban.

I will do as you suggest.

Ed
Ed McD is offline   Reply With Quote
Old 06-15-2016, 06:10 AM   #8
Ed McD
Junior Member
 
Join Date: Jun 2016
Posts: 7
Default Dynadock 4K DisplayLink Support Tool Result - Zip File - Second Submission

Alban, I've followed your instructions to the letter several times. The last time, after uninstall, I searched the hard drive for any items that said "DisplayLink." The search located a number of small files and folders. I tried to delete as many as I could. Then I ran the cleaner, rebooted, and ran the cleaner again and rebooted. I then re-installed 7.9 M7 as instructed. At the end, after it asked to connect the dock, which I did, i tried to configure the display as a "custom" display, adding a monitor, but the software found no dock and no monitor. No icon appears in the taskbar. The list of "apps" has no mention of DisplayLink at all.

I've run the Support Tool again. The zip file is attached.

Ed McDevitt
Attached Files
File Type: zip LAPTOP-LVCVE267_20160614_234519.zip (1.33 MB, 2 views)
Ed McD is offline   Reply With Quote
Old 06-16-2016, 09:30 AM   #9
AlbanRampon
Senior Member
 
AlbanRampon's Avatar
 
Join Date: Sep 2015
Location: Cambridge, UK
Posts: 1,629
Arrow

Hello Ed,

Thank you for that.
On that version of our software, the icon will only be displayed when everything is working:
  1. Software present: Yes, I checked it is there.
  2. A dock connected: Yes, I checked it is recognised.
  3. A monitor is connected: No. There is no monitor detected as plugged in by the dock. So there is no monitor identification read (EDID) and no monitor reported to the computer and the dock just waits.

May I advise you check the cables between the dock and the monitor?
You could try with another cable. If nothing happens, then there is a hardware fault with the hotplug detection in the Dynadock.

Kind regards,
Alban
__________________
Alban Rampon
Senior product manager, universal docking stations and accessories
"DisplayLink is proud to be a Synaptics brand."

Where to download the latest DisplayLink drivers
How to clean up a corrupted installation
How to report issues to DisplayLink for a speedy resolution
AlbanRampon is offline   Reply With Quote
Old 06-22-2016, 05:54 PM   #10
Ed McD
Junior Member
 
Join Date: Jun 2016
Posts: 7
Default

Thanks, Alban. It turned out that the DVI cable that connected the Dynadock to the second montitor wasn't working - at least not between those two, though it does work between another computer and the monitor. I direct-connected the monitor to my computer via VGA and it works; and the Dynadock otherwise works fine.

I really do wish that Toshiba were a little less sloppy in directions. The setup doc that comes with the Dynadock directed me to a software download web site that's dead. I finally got the the Toshiba site that gives the 6 possibilities for Dynadock software without any indication which one is the right one; certainly there's no warning not to overlay one with another if the first one doesn't seem to work. All this does is to put the burden back on your company to fix their carelessness.

I very much appreciate your hanging in and helping. It is good to know that there are companies and people out there like you.

Thanks again.

Ed McDevitt
Ed McD is offline   Reply With Quote
Reply

Tags
dynadock 4k, satellite s70, toshiba, win 10

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.