Go Back   DisplayLink Forum > Alpha, Beta Software Testing Programs > Closed Alpha and Beta Programs > Closed: 8.5 Beta for Windows

 
 
Thread Tools Search this Thread Display Modes
Old 05-14-2018, 06:02 AM   #1
sean3047
Junior Member
 
Join Date: May 2018
Posts: 1
Default 8.5 Beta 1 Feedback

Just thought I'd share my experience with the 8.5 Beta 1 drivers (alternative encoder enabled).

I'm using a Lenovo USB 3.0 Ultra Dock, driving two 1080p monitors, one via HDMI, the other via DisplayLink. The attached laptop is a T470s (i5-7200, 12GB RAM, Intel 620).

When watching video on the DisplayLink connected display, CPU usage is still high, although better than before. The driver is peaking at about 24% CPU usage, but normally hovers around 12-18% when watching Netflix.

Video quality (in terms of compression artefacts) is noticeably worse (but good enough), I assume this is expected from the use of alternative encoder. Frame rate is massively improved from earlier (again, not great, but a very noticeable improvement).

Can we expect to see a performance fix for non-Intel GPUs? My other laptop has a Nvidia 1050, and at the moment, I resort to plugging it in directly to the monitor via HDMI, meaning my second monitor goes unused.
sean3047 is offline  
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.