Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Mac Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 07-03-2018, 09:31 PM   #391
Neo.aka.Darkman
Junior Member
 
Join Date: Feb 2018
Location: Freiburg, Germany
Posts: 7
Default

On Mojave Beta 3 driver is not working anymore. No Airplay. I see monitor in System Preferencies - Display. Monitor becomes active when Itake mouse cursor over there, but it is always black screen. (on this black screen I can see mouse cursor)
Neo.aka.Darkman is offline   Reply With Quote
Old 07-03-2018, 11:25 PM   #392
Okibi
Junior Member
 
Join Date: Apr 2018
Posts: 8
Default

Thanks Neo,

I had logged in to see if anyone had tried the third Beta of macOS 10.14

Sad to see no progress.

This issue needs to be made more public so Apple is forced to respond.

MC Ren you obviously didn't try apples dodgy USB-C to HDMI dongles before buying your displaylink product, they were absolute garbage that caused an endless loop of discovering the first monitor, refreshing, discovering the second monitor and losing the first monitor, refreshing, then discovering the first monitor and losing the second monitor ... and so on.
Okibi is offline   Reply With Quote
Old 07-04-2018, 06:29 AM   #393
Neo.aka.Darkman
Junior Member
 
Join Date: Feb 2018
Location: Freiburg, Germany
Posts: 7
Default

Quote:
Originally Posted by Okibi View Post
This issue needs to be made more public so Apple is forced to respond.
As I've already said above: it's all about external graphic adapters. In 10.13.4 Apple began to provide native support for external GPUs. They have rewritten large parts of IOGraphicsFamily.kext, what brings us to the point, that all virtual graphic adapters are now unusable.
DisplayLink has reached some progress using AirPlay Technology, but since Mojave beta 3 it's broken.
Neo.aka.Darkman is offline   Reply With Quote
Old 07-04-2018, 10:51 AM   #394
Wozzy
Member
 
Join Date: Mar 2018
Posts: 35
Default

Quote:
Originally Posted by Neo.aka.Darkman View Post
As I've already said above: it's all about external graphic adapters. In 10.13.4 Apple began to provide native support for external GPUs. They have rewritten large parts of IOGraphicsFamily.kext, what brings us to the point, that all virtual graphic adapters are now unusable.
DisplayLink has reached some progress using AirPlay Technology, but since Mojave beta 3 it's broken.
You are testing beta software on a developer release and you expect it to work

DL need to get a final driver out for HS first. Enterprises that use DL are not going to want to distribute beta software.
Wozzy is offline   Reply With Quote
Old 07-04-2018, 11:46 AM   #395
stfm
Junior Member
 
Join Date: Jul 2016
Posts: 24
Default

Quote:
Originally Posted by MC Ren View Post
Never had a problem with any accessory, etc with 5 macs I've owned, except with this BS display link issue. I'd hardly say this happens with Apple all the time. Maybe you are better off with sticking with microsoft products...
Well, that depends on what accessories you have of course. I have had to get rid of a Canon scanner, two printers and a Wacom tablet. This happens on Windows also, but not on a small automatically installed release. I've had macs since the early-mid 90's, only briefly owning Windows computers, and it's a fairly recent development. Windows blows in most other respects, and updates can certainly destroy your computer, but it's often possible to recover.
stfm is offline   Reply With Quote
Old 07-04-2018, 09:22 PM   #396
AlbanRampon
DisplayLink Tech Support
 
AlbanRampon's Avatar
 
Join Date: Sep 2015
Location: Cambridge, UK
Posts: 1,409
Arrow

Update: July 4th

Dear DisplayLink macOS users,

Installing macOS 10.13.4, or newer, will cause DisplayLink connected displays to go blank after the OS update when using DisplayLink driver v4.1. Extended displays continue to work as expected in macOS 10.13.3 and below.
Functionality such as Ethernet and audio, where implemented, is unaffected.

DisplayLink driver v4.3 beta 5 currently provides an interim solution with one extended USB display (720p or 1080p) on macOS 10.13.4, 10.13.5 and 10.14 first two developer previews, using Apple AirPlay® on machines with that feature. All additional DisplayLink screens will be cloning the primary display.
An FAQ details how to enable Apple AirPlay with DisplayLink display for extend or mirror mode.
The third developer preview of 10.14 has changed behaviour, as already exposed here. Displays using DisplayLink technology will be present in System Preferences - Display. The displays can be activated, and the mouse is visible, but otherwise the displays are black. Should you have already installed that OS version, simply use DisplayLink driver v4.3 beta 6 to force the AirPlay interim whilst the work continues.
We do not recommend using that OS version for extended desktop changes as it brings no benefit compared to previous versions. It also adds an undesired audio switch at reboot to be addressed.
When a new version brings value, we will obviously notify you.

Our team continues to progress towards a solution which would both restore full extended display support for multiple DisplayLink displays in a future release of macOS and defend that functionality in the future. As daily users of the technology ourselves, we truly understand how disruptive this loss of functionality affecting the full ecosystem can be. Despite getting closer to tell more about roll out, we stay unable to provide a time-frame or a date for release of this solution.
We will keep providing updates to this message.

Thank you for your extended patience. We appreciate your feedback and support.
AlbanRampon is offline   Reply With Quote
Old 07-05-2018, 03:19 PM   #397
Poly
Member
 
Join Date: Oct 2017
Posts: 36
Default

Ok, the fix will eventually be released in Autumn/Winter...

While you are working on the "ultimate fix" could you please also address the annoying HDCP problem?

__________________
MacBook 12-inch (Early 2016) • MacBook Pro 15-inch (2018) • HP Elite USB-C-Docking Station G2 (X7W54AA) • HP 3005PR • Dell Adapter USB-C HDMI/VGA/Ethernet (470-ABQN)
Poly is offline   Reply With Quote
Old 07-06-2018, 08:53 AM   #398
AlbanRampon
DisplayLink Tech Support
 
AlbanRampon's Avatar
 
Join Date: Sep 2015
Location: Cambridge, UK
Posts: 1,409
Arrow

Quote:
Originally Posted by Poly View Post
While you are working on the "ultimate fix" could you please also address the annoying HDCP problem?

Hello Poly,
To implement HDCP properly on Windows 10 for indirect displays, this took the collaboration of Microsoft, Intel, DisplayLink and software player vendors (CyberLink for PowerDVD, Netflix and Amazon are just a few).
The manufacturer must be member of the DCP to have HDCP keys in the device. It's not enough that DisplayLink is.
Then you have to see which HDCP version as they have different DRM requirements...
HDCP 1.x is usually what is needed for 1080p playback, but on Windows 10, it required a GPU supporting HDCP 2.2.
It is in the roadmap, but building good foundations seems to be the right priority today.
Kind regards,
Alban
AlbanRampon is offline   Reply With Quote
Old 07-06-2018, 09:39 AM   #399
donluca
Junior Member
 
Join Date: Jun 2018
Posts: 21
Default

Quote:
Originally Posted by Neo.aka.Darkman View Post
They have rewritten large parts of IOGraphicsFamily.kext, what brings us to the point, that all virtual graphic adapters are now unusable.
Wait, so if I put that kernel extension from a 10.13.3 installation over to my actual 10.13.5 displaylink will work again as intended?

I remember I did the same with an audio extension to get Integer Playback again, maybe it could be a nice workaround without re-installing everything from scratch?

Please let me know if anyone has tried this.
donluca is offline   Reply With Quote
Old 07-06-2018, 01:15 PM   #400
daan
Junior Member
 
Join Date: May 2018
Posts: 9
Default

Quote:
Originally Posted by donluca View Post
Wait, so if I put that kernel extension from a 10.13.3 installation over to my actual 10.13.5 displaylink will work again as intended?

I remember I did the same with an audio extension to get Integer Playback again, maybe it could be a nice workaround without re-installing everything from scratch?

Please let me know if anyone has tried this.
Yeah this might be worth exploring, on a hackintosh. Anyone got time for it?
daan is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.