Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Mac Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 10-17-2019, 02:16 PM   #1
Keanu
Junior Member
 
Join Date: Oct 2019
Posts: 3
Question Internal Macbook Pro screen goes black!

Hi there,

in our company we use your docking stations for Mac OS. We have the following problem:

We work with 2 external displays. The Macbook Pro display is closed. After a while if we want to go to a meeting and just unplug the Macbook Pro from USB-C and open the internal screen, it stays black and we have to reboot to get the internal display to work again. I tried the newest BETA drivers for Mac but it just does not want to work and is a huge pain.

We use this docking station.
https://us.targus.com/products/usb-c...wer-dock180usz

I even tried https://support.displaylink.com/know...r-only-one-mon but it did not help either. Re-installing the driver does not help.

I'm personally on Catalina and can't get this to work. Any ideas?

Best regards
Keanu

Last edited by Keanu; 10-17-2019 at 03:11 PM.
Keanu is offline   Reply With Quote
Old 10-20-2019, 08:54 PM   #2
Quatenga
Junior Member
 
Join Date: Oct 2019
Posts: 2
Default

Hello,

I have the same Problem.

I tried already all three workarounds:
https://support.displaylink.com/know...ing-permission
https://support.displaylink.com/know...-functionality
https://support.displaylink.com/know...r-only-one-mon

Nothing helps.
I also downgraded again to Mojave and tried different Versions of the DisplayLink driver on Mojave and Catalina.


I have also the problem that some applications are not working or not working properly when I'm in Camshell mode.
- Final Cut Pro X is not starting at all.
- Affinity Designer is starting, but if I try to create a new Document, I got only the "loading ball" and that's it.
- Affinity Photo for example is working properly.

If I'm not in the Camshell mode, so Macbook display is still opended and working, then I don't have problems with the applications. Also after enabling Camshell mode after starting the applications, everything is working. But if I'm opening the Macbook again, internal Display stays black.
Quatenga is offline   Reply With Quote
Old 10-22-2019, 12:27 PM   #3
Keanu
Junior Member
 
Join Date: Oct 2019
Posts: 3
Default

I talked to DisplayLink. This is a known issue and they work together with Apple to resolve this. I assume it will take ages until it is fixed.

"[...] we believe the problem is with the Intel driver, or possibly on dual graphics systems, a bug when the OS is switching between the GPUs going in an out of clamshell mode. "
Keanu is offline   Reply With Quote
Old 11-08-2019, 09:17 AM   #4
jalmargyyk
Junior Member
 
Join Date: Nov 2019
Posts: 1
Default

I'm using I-TEC dock CADUAL4KDOCK and I'm facing the same issue if clamshell mode is used. The driver is the latest available (5.2.1 Beta 3 16 Oct 2019).

One observed thing with clamshell mode:
- Using Google Chrome and e.g. Facebook, "beach ball" appears sometimes and the whole browser freezes completely for a few seconds. After that symptom is observed, I've been unable to end the Google Chrome process and the only workaround has been a forced to shutdown with hard reset (hold power button down for 10s).

Now that I have kept the lid open, all the symptoms have gone and everything is working as it should. This is a poor workaround, but it's the only one that is currently working properly.
jalmargyyk is offline   Reply With Quote
Old 11-18-2019, 02:52 PM   #5
piotr.czarny
Junior Member
 
Join Date: Nov 2019
Posts: 1
Default

Same issue with a 2016 MacBook Pro and Catalina 10.15.1, Displaylink beta3 driver (Oct 16 2019).
  • the built in display stays off after undocking
  • Java Applications can not launch
  • Chrome browser freezes
piotr.czarny is offline   Reply With Quote
Old 11-23-2019, 08:39 PM   #6
Quatenga
Junior Member
 
Join Date: Oct 2019
Posts: 2
Default Solved

Hi,

I've found a solution for me.
I updated my Macbook back to Catalina and also updated the final DisplayLinkDriver (no Beta version).

Then I switched off the automatic change between the graphic cards when a power supply is connected.
Here is a manual how to do it:
https://support.apple.com/en-us/HT202043

After that all my programm are working properly again and also the internal macbook displays comes up again after the clamshell mode.
Quatenga is offline   Reply With Quote
Old 11-25-2019, 12:37 PM   #7
et758685
Junior Member
 
Join Date: Nov 2019
Posts: 1
Default

Quote:
Originally Posted by Quatenga View Post
Hi,

I've found a solution for me.
I updated my Macbook back to Catalina and also updated the final DisplayLinkDriver (no Beta version).

Then I switched off the automatic change between the graphic cards when a power supply is connected.
Here is a manual how to do it:
https://support.apple.com/en-us/HT202043

After that all my programm are working properly again and also the internal macbook displays comes up again after the clamshell mode.
Really hoping this solves the issue. I've disabled this setting. We'll see how things go by end of day when I open lid.

I observed that things seemed to work fine for a "little while" after logging in but at some point the internal display will begin refusing to turn on.
et758685 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.