Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Mac Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 09-25-2018, 12:45 AM   #1
brossow
Junior Member
 
Join Date: Sep 2018
Posts: 10
Default Sabrent hub + external monitor not working with Mojave/5.0 driver

Subject says it all, really. Ever since the update to 10.13.4, my wife's MacBooks haven't worked with her external monitor. We were able to get it kinda-sorta working with the hacky AirPlay workaround on her previous MacBook Air, but we updated her brand-new MacBook Air to Mojave and installed the new 5.0 driver this afternoon and nothing. Just a black screen -- knows it's connected to the dock because the power light is one, but nothing on the screen and the computer doesn't see anything is connected. Was working fine with the same dock, monitor and cable until 10.13.4 so no reason it shouldn't work now. The monitor and cable are fine because it works fine when plugged into a DisplayPort adapter. Very disappointing, to say the least. Any solution?
brossow is offline   Reply With Quote
Old 09-25-2018, 01:46 AM   #2
brossow
Junior Member
 
Join Date: Sep 2018
Posts: 10
Default

FWIW, I've also tried with a different identical dock (Sabrent USB 3.0 Universal Docking Station, to be specific), different monitor, and different connection (HDMI instead of the DVI-to-VGA cable for my wife's regular monitor). No luck. It seems to get so far, because the monitor wakes up when rebooting the computer and once booted flickers briefly as if it's actually going to work, but then nothing. Same with both monitors.
brossow is offline   Reply With Quote
Old 09-25-2018, 02:14 PM   #3
bcg123
Junior Member
 
Join Date: Sep 2018
Posts: 2
Default

I am having the same troubles, i am using a 2017 Macbook Air with a USB 3.0 to HDMI Adapter. The second screen is just showing up as black, the monitor seems to register that it is connected but the Computer doesnt recognize that a second screen is available and there are no display options.

The problem started when updating to 10.13.4 and i haven't been able to get the second screen to work since. I was hopeful that the 10.14 update would fix that issue but it seems to be more of the same.
bcg123 is offline   Reply With Quote
Old 09-25-2018, 02:21 PM   #4
brossow
Junior Member
 
Join Date: Sep 2018
Posts: 10
Default

Quote:
Originally Posted by bcg123 View Post
I am having the same troubles, i am using a 2017 Macbook Air with a USB 3.0 to HDMI Adapter. The second screen is just showing up as black, the monitor seems to register that it is connected but the Computer doesnt recognize that a second screen is available and there are no display options.

The problem started when updating to 10.13.4 and i haven't been able to get the second screen to work since. I was hopeful that the 10.14 update would fix that issue but it seems to be more of the same.
Indeed, the sole reason we updated to Mojave was because this was supposed to work. At least 4.3 was working with the AirPlay hack. Even though the quality was terrible, at least she had that second monitor. Now she's got nothing.

I used the support tool and sent logs off to tech support last night. Hopefully they'll be able to get this fixed quickly.
brossow is offline   Reply With Quote
Old 09-25-2018, 05:04 PM   #5
ccd
Junior Member
 
Join Date: Sep 2018
Posts: 2
Default Same Issue

Same issue. Thanks for the link to the support tool. I submitted a log just now as well. THis is very frustrating.
ccd is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.