Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Windows Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 07-11-2018, 04:29 PM   #1
macedot
Junior Member
 
Join Date: Jul 2018
Posts: 1
Default Dynadock U3 not working properly with USB 3.0

SOLVED

Dock unit in question: Toshiba Dynadock U3 (PA3927A-1PRP)

I'm creating this post for future reference since some awkward issues definitively tend to repeat. James C from DisplayLink UK is helping me providing directions about what to test. The content bellow summarize our tests results.

The issue described at this post seems to be the same one described here:
https://forum.toshiba.eu/showthread....ork-on-USB-3-0

Seems that this unit (?) has some issues trying to "handshake" USB 3.0 stuff with Host Controller that somehow avoid some features of being detected by the OS.

All tests presented are based on Windows 10 Pro, but the same machine dual boots to an Ubuntu 18 and symptoms are exactly the same. The Mac book at test case 01 is only presented for sanity check and to 'proof' that the unit is nominal.

UPDATE: James conclusion is that either something is wrong with my laptop, or maybe the dock USB 3.0 cable isn't working properly. Will try to find another computer with USB 3.0 or another cable for the dock.

UPDATE: James was right: a faulty dock cable was the reason. Once replaced, all dock features were properly recognized.

Test cases:
Test cases 01: Mac Book 2009-ish: Only USB 2.0 ports (2x); Mac OS El Capitan;
  • Working out of the box (no additional driver installation necessary):
    • USB HUB
    • Ethernet
  • Untested:
    • Audio
    • DisplayLink HDMI/DVI

Test cases 02: Razer Blade 14 2017 (B6) : USB 3.0 ports only; Windows 10 Pro/Ubuntu Mate 18;
  • Working out of the box (no additional driver installation necessary):
    • USB HUB
  • Not working (DisplayLink 8.5 M2 driver; devices not identified by windows; not appear at Device Manager, not even as 'Unknown devices'):
    • Ethernet
    • Audio
    • DisplayLink HDMI/DVI

Test cases 02a: Razer Blade 14 2017 (B6) + USB 2.0 HUB
  • Working after driver installation:
    • USB HUB
    • Ethernet
    • Audio
    • DisplayLink HDMI/DVI

Test cases 03.1: Razer Blade 14 2017 (B6) + Sandisk USB 3.0 Flash Drive: DisplayLink 8.5 M2
  • When connected to a USB 2.0 port on the dock:
    • Sandisk USB 3.0 Flash Drive falls back to USB 2.0 and is recognized by the OS
  • When connected to a USB 3.0 port on the dock:
    • Sandisk USB 3.0 Flash Drive is not recognized by the OS

Test cases 03.2: Razer Blade 14 2017 (B6) + Peripherals (Keyboard; mice receiver) : DisplayLink 8.5 M2
  • When connected to a USB 2.0 port on the dock:
    • Recognized by the OS and performs nominally;
  • When connected to a USB 3.0 port on the dock:
    • Recognized by the OS and performs nominally;
Attached Files
File Type: zip USBViewAll.zip (12.1 KB, 0 views)
File Type: zip DL_Windows_Logs_20180711_131056.zip (1.74 MB, 0 views)

Last edited by macedot; 07-13-2018 at 06:26 AM. Reason: typos; reformatting; update;
macedot is offline   Reply With Quote
Reply

Tags
dynadock u3, linux, pa3927a-1prp, usb 3.0, windows

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.