Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Windows Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-24-2022, 11:39 PM   #1
smmalis37
Junior Member
 
Join Date: Jan 2022
Posts: 3
Default Shaking cursor with EnableGammaRamp = true

I am running Windows 11 version 21H2 (build 22000.438) with DisplayLink version 10.1.2875.0. I have manually gone into my registry and set HKLM\SOFTWARE\DisplayLink\Core\EnableGammaRamp to "true" so that I can have Windows Night Light function correctly. While this does work, it comes with the side effect of my mouse cursor looking absolutely bizarre when it's on a display connected to the DisplayLink adapter. The mouse cursor looks perfectly normal on displays connected to my GPU. Here is a video of the issue I took with my phone: https://www.youtube.com/watch?v=wqItUXxwAMA. Note that my hand is completely off the mouse during that recording. Disabling the registry key fixes this issue, but then I can't use Night Light. Any suggestions?
smmalis37 is offline   Reply With Quote
Old 02-01-2022, 06:04 PM   #2
AlbanRampon
Senior Member
 
AlbanRampon's Avatar
 
Join Date: Sep 2015
Location: Cambridge, UK
Posts: 1,644
Arrow

Hello,

I'm afraid that is the reason why the feature is in beta rather than enabled by default.

Can you please share your monitor make and model?
We are revisiting the feature to see if we can address that issue, but I don't have feasibility yet.

Regards,
Alban
__________________
Alban Rampon
Senior product manager, universal docking stations and accessories
"DisplayLink is proud to be a Synaptics brand."

Where to download the latest DisplayLink drivers
How to clean up a corrupted installation
How to report issues to DisplayLink for a speedy resolution
AlbanRampon is offline   Reply With Quote
Old 02-01-2022, 08:25 PM   #3
smmalis37
Junior Member
 
Join Date: Jan 2022
Posts: 3
Default

The monitor connected to the displaylink adapter is a LG 27QN880-B.
smmalis37 is offline   Reply With Quote
Old 02-01-2022, 08:30 PM   #4
AlbanRampon
Senior Member
 
AlbanRampon's Avatar
 
Join Date: Sep 2015
Location: Cambridge, UK
Posts: 1,644
Arrow

Thanks.
Would you mind trying at 60Hz? It's selectable in advanced monitor settings. I can explain if you don't know where to find that.
__________________
Alban Rampon
Senior product manager, universal docking stations and accessories
"DisplayLink is proud to be a Synaptics brand."

Where to download the latest DisplayLink drivers
How to clean up a corrupted installation
How to report issues to DisplayLink for a speedy resolution
AlbanRampon is offline   Reply With Quote
Old 02-01-2022, 09:17 PM   #5
smmalis37
Junior Member
 
Join Date: Jan 2022
Posts: 3
Default

When connected to the DisplayLink adapter Windows does not give me the option for 75hz, only 60. So I have already tried that.
smmalis37 is offline   Reply With Quote
Old 02-01-2022, 09:49 PM   #6
AlbanRampon
Senior Member
 
AlbanRampon's Avatar
 
Join Date: Sep 2015
Location: Cambridge, UK
Posts: 1,644
Arrow

Would you please be able to upload logs? The third link in my forum signature shows the tool and steps. Only support personnel will be able to access the attachment.
I'd like to see monitor details (timings), and available modes. I found tests we made a couple of years ago and now understand why 60 Hz has the trembling mouse cursor.
__________________
Alban Rampon
Senior product manager, universal docking stations and accessories
"DisplayLink is proud to be a Synaptics brand."

Where to download the latest DisplayLink drivers
How to clean up a corrupted installation
How to report issues to DisplayLink for a speedy resolution
AlbanRampon is offline   Reply With Quote
Old 09-16-2022, 06:07 PM   #7
Rwmnau
Junior Member
 
Join Date: Sep 2022
Posts: 1
Default

I had this same issue with a shaky cursor once I enabled this flag and it was resolved by moving my refresh rate from 75hz down to 60hz. However, with this flag enabled, my mouse click was registering about one cursor-width left of where I was actually clicking. This only happened on the two external DisplayLink monitors - my internal laptop monitor was file. Removing this flag and unplugging/replugging the dock with the monitors resolved it and now my clicks are accurate again.

Is there a workaround for this issue as part of the flag too? I'd like to enable the night mode on my monitors but these bugs are really odd.
Rwmnau is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:12 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.