Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Windows Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 10-25-2013, 01:07 AM   #1
NickinVA
Junior Member
 
Join Date: Oct 2013
Posts: 3
Lightbulb FIXED - 8.1 Issue w/ Kensington SD3500v

I am pleased to report that after many hours and much gnashing of teeth, I fixed my own issue after the 8.1 upgrade, and I thought I would post here so it would be searchable.

Apparently, although USB 3.0 is supposed to be fully supported by Windows drivers - some 3.0 devices don't play well.

The Kensington SD3500v was not being recognized as a 3.0 device, and would show a yellow hazard "!" in the Device Manager. The fix is to load intel 3.0 host drivers in place of the Microsoft ones. Once you do that, and achieve communication with the device, you can update firmware, and move forward. Intel doesn't seem to know about this, since it won't allow you to use it's drivers with the native loader, saying your hardware is not compatible. Follow the directions here:

http://plugable.com/2012/12/01/windo...st-controllers

Works like a champ!
NickinVA is offline   Reply With Quote
Reply

Tags
8.1, docking station, sd3500v, usb 3.0 host

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.