Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 03-12-2017, 03:07 PM   #1
PeterPetrus
Junior Member
 
Join Date: Mar 2017
Posts: 1
Default Screen turns black and external monitor is not detected

Hi,

I am trying to get my i-tec USB 3.0 Docking station to work with a fresh installation of Ubuntu 16.04 on my Lenovo Yoga 3 14".
I downloaded the latest release of the driver (1.3.52) and followed these instructions. In addition to step 1-7 I also copy pasted both sudo apt-get install commands from the text above.
The ouput of the install script stops after "Adding udev rule for DisplayLink DL-3xxx//5xxx devices". According to the instructions "Starting DLM upstart job" and "displalink start/running, process 3397" should also be printed.

When I connect my docking station, the screen turns black after a few seconds. Only the following output is displayed: "/dev/sda3: clean, 256536/1250928 files, 1498229/4999936 blocks". I have to disconnect the docking station in order to successfully boot again.

Then I tried the steps from these two threads One and Two. Both follow a similar approach to force usage of upstart instead of systemd.

But still the last two output lines are missing and no external monitor is detected. This screen turning black thing does only occur when systemd is used which is the default case for Ubuntu 16.04 (from my understanding).

Another information I can add: Even after uninstallation of the driver I receive one or two Ubuntu internal errors after each system start which is annoying. (Will post the messages later on).

Last thing: I managed to use the external monitor successfully via the docking station once during all my research and test activities but this lasted only until the next reboot. I have no idea how I did this and could not reproduce it, but there is some hope.

Any ideas? What else can I try or am I doing something wrong?

Regards
PeterPetrus is offline   Reply With Quote
Reply

Tags
16.04, docking station, systemd, ubuntu, upstart

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.