Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Mac Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 05-14-2024, 11:07 AM   #1
alexcstanley
Junior Member
 
Join Date: May 2024
Posts: 1
Default Updated to macOS Sonoma 14.5...

... and now my screen connected by DisplayLink isn't working

I can see that the Apple System Report can see the DisplayLink adapter connected to USB, but no amount of unplugging and replugging the screen is working. I can see in the DisplayLink Manager that it doesn't think anything is connected.

Any suggestions please?

Thanks
alexcstanley is offline   Reply With Quote
Old 05-14-2024, 03:42 PM   #2
scampbell6
Junior Member
 
Join Date: May 2024
Posts: 3
Default

same issue pretty much for everyone on desktop Sonoma 14.4.1. In Security settings of macOS, we no longer have the option to allow the USB and display link has become a brick. Support here will just redirect you to the hardware manufacturer who will redirect you back to displaylink who will redirect you back to the hardware manufacturer. Clearly it's a software issue and displaylink has become useless unfortunately with support that won't acknowledge the problem since the Sonoma 14.4.1 update.
scampbell6 is offline   Reply With Quote
Old 05-16-2024, 03:49 PM   #3
rasheemjones16
Junior Member
 
Join Date: Apr 2024
Posts: 1
Angry

Having same issue....DisplayLink Manager is say that there is no DisplayLink-enabled display detected. It was working just fine 2 days. I hope some support comes soon.
rasheemjones16 is offline   Reply With Quote
Old 05-16-2024, 06:43 PM   #4
colorcritical
Junior Member
 
Join Date: May 2024
Posts: 2
Smile Updated to macOS 14.5 Sonoma

I upgraded to macOS 14.5 today and almost expected DeviceLink to not work. Sure enough it didn't after I finished the update.

I uninstalled DeviceLink from Apps and reinstalled it again, rebooted and it still didn't see my two HP displays.

I shut down my MacBook and unplugged my USB-C Dock. I rebooted my MacBook and plugged the power to the Dual Display USB-C Dock and opened Device Link, only to notice I needed to re-install the extension again (found under Support tab). I rebooted again.

This must have reset preferences, Because I had to manually start DeviceLink from Applications and then manually reselect "Launch automatically after login".

This seemed to work and I am now back up and running with macOS 14.5 and Device Link Manager 1.10.1(Build 93) with two hp Z24n G2 displays.

- Marc

Last edited by colorcritical; 05-16-2024 at 06:47 PM.
colorcritical is offline   Reply With Quote
Old 05-19-2024, 09:07 PM   #5
LAecho
Junior Member
 
Join Date: May 2024
Posts: 1
Default

Hello, I have the same issue. Where did you find the extension? I didn't see it on the support tab, thanks!
LAecho is offline   Reply With Quote
Old 05-21-2024, 05:02 AM   #6
abdullah
Junior Member
 
Join Date: May 2024
Posts: 2
Default No Display detected after Sonoma Update

Same happened with me. has anyone found any solution or alternative? its really urgent
abdullah is offline   Reply With Quote
Old 05-21-2024, 05:22 AM   #7
abdullah
Junior Member
 
Join Date: May 2024
Posts: 2
Default

Quote:
Originally Posted by colorcritical View Post
I upgraded to macOS 14.5 today and almost expected DeviceLink to not work. Sure enough it didn't after I finished the update.

I uninstalled DeviceLink from Apps and reinstalled it again, rebooted and it still didn't see my two HP displays.

I shut down my MacBook and unplugged my USB-C Dock. I rebooted my MacBook and plugged the power to the Dual Display USB-C Dock and opened Device Link, only to notice I needed to re-install the extension again (found under Support tab). I rebooted again.

This must have reset preferences, Because I had to manually start DeviceLink from Applications and then manually reselect "Launch automatically after login".

This seemed to work and I am now back up and running with macOS 14.5 and Device Link Manager 1.10.1(Build 93) with two hp Z24n G2 displays.

- Marc

this didn't work for me
abdullah is offline   Reply With Quote
Old 05-23-2024, 06:24 PM   #8
aguilar_mj
Junior Member
 
Join Date: May 2024
Posts: 1
Default

Quote:
Originally Posted by abdullah View Post
this didn't work for me
turn off the docker andt try
aguilar_mj is offline   Reply With Quote
Old 05-24-2024, 01:14 PM   #9
Nicojons
Junior Member
 
Join Date: May 2024
Posts: 2
Default

Same for me.
After I installed Sonoma 14.5
Displaylink manager stop working.
So I uninstalled Displaylink manager, I reinstalled it again.
I shutdown my mac and unplugged my dock.
I rebooted my mac plugged the dock. I resinstalled the displaylink extension.
I rebooted again.
with all of it the app doesnt work.

Please I need help from support.
Nicojons is offline   Reply With Quote
Old 05-24-2024, 01:43 PM   #10
Nicojons
Junior Member
 
Join Date: May 2024
Posts: 2
Default

After a few hours of trying to get the Displaylink manager to work.
I restarted the operation but when unplugging the dock I also unplugged all the devices.
And now the app reworks correctly.
Nicojons is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.