Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Mac Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-24-2017, 10:26 AM   #61
Johan
Junior Member
 
Join Date: Nov 2017
Posts: 4
Default

Turns out my black screen issues were the cause of mirroring as well. I did not think it was the issue since this setup was without mirroring before upgrading to high sierra, but it seems my display settings where reset during the upgrade and for some reason, osx defaults to mirroring.

Trouble was that my mouse cursor got locked when I logged in (after getting kicked out), so I couldent deactivate the mirroring even with system settings open. Tab just took me to the search input field.

I solved it by finding the shortcut for toggling mirroring, which was cmd+"screen brightness down". For newer macbook pros, expand control strip and its to the far left.

After that all screens came alive. Puh!

Last edited by Johan; 11-24-2017 at 10:29 AM.
Johan is offline   Reply With Quote
Old 11-25-2017, 04:12 PM   #62
wa2flq
Junior Member
 
Join Date: Jun 2017
Posts: 5
Default

Quote:
Originally Posted by Carlo View Post
Most remaining issues are cosmetic, we keep an updated list of the most important issues here: http://support.displaylink.com/knowl...rticles/949426

I hope you'll appreciate the effort of transparency here: I'm not aware of any other product suffering from the same issues coming clean about these compatibility problems.

Eh.

Regards
Carlo
Definitely appreciated. I have seen a few of these cosmetic issues, but the speed and stability of the product otherwise has been very good!
wa2flq is offline   Reply With Quote
Old 11-27-2017, 02:50 PM   #63
rbryant76
Junior Member
 
Join Date: Nov 2017
Posts: 1
Default

Anyone having issues with Apple Watch not unlocking the system anymore?

When I have the device plugged in and drivers installed, Apple Watch can't unlock the Mac anymore.

Removing the device and installing drivers - Apple Watch unlocks fine....
rbryant76 is offline   Reply With Quote
Old 11-28-2017, 07:32 AM   #64
Carlo
Mac Team
 
Carlo's Avatar
 
Join Date: Feb 2009
Posts: 590
Default

Quote:
Originally Posted by rbryant76 View Post
Anyone having issues with Apple Watch not unlocking the system anymore?

When I have the device plugged in and drivers installed, Apple Watch can't unlock the Mac anymore.

Removing the device and installing drivers - Apple Watch unlocks fine....
Hi,

We haven't tried this directly, but what we know is that as soon as a virtual screen is connected to the graphics subsystem, macOS disables content protection from ALL screens.
This may include information potentially accessible through the Apple Watch security, it would make sense.

We have contacted Apple and this is apparently as designed. This in our opinion unnecessary: the internal screens support content protection and should be kept running as usual. We are also disappointed of course since we do support HDCP in our products and there is no way for us in macOS to offer content protection capabilities...

Anyhow, I'd suggest to open a bug with Apple about this issue: the more tickets, the higher the chances of changing the OS behaviour.

Regards
Carlo
Carlo is offline   Reply With Quote
Old 11-29-2017, 07:07 PM   #65
paultzirides
Member
 
Join Date: Jun 2013
Posts: 37
Default Bug report submitted

Thanks for the explanation, that makes sense. I agree that it should still allow for watch unlock and HDCP-protected content playback on supported screens.,
paultzirides is offline   Reply With Quote
Old 11-30-2017, 06:03 AM   #66
Johan
Junior Member
 
Join Date: Nov 2017
Posts: 4
Default

So I finally got my screens working, but now Im getting logged out everytime I pull the plug on my external screens, when going to meetings with my computer etc. And sometimes when I get back to my desk as well. Everything I was working non gets reset, like connections to vpn, ongoing builds, vnc connections, my virtual machines get super crashed etc.

Really frustrating. Only happens when using the display link screens.

Any progress on this issue?




Quote:
Originally Posted by Johan View Post

Displaylink adapter 1 info:
USB3.0 UHD DisplayPort Adapter:

Product ID: 0x4301
Vendor ID: 0x17e9 (DisplayLink (UK) Ltd.)
Version: 35.80
Serial Number: 000100160348300
Speed: Up to 5 Gb/sec
Manufacturer: DisplayLink
Location ID: 0x02620000 / 7
Current Available (mA): 900
Current Required (mA): 504
Extra Operating Current (mA): 0


Displaylink adapter 2 info:
USB3.0 UHD DisplayPort Adapter:

Product ID: 0x4301
Vendor ID: 0x17e9 (DisplayLink (UK) Ltd.)
Version: 35.80
Serial Number: 000100160348266
Speed: Up to 5 Gb/sec
Manufacturer: DisplayLink
Location ID: 0x02500000 / 2
Current Available (mA): 900
Current Required (mA): 504
Extra Operating Current (mA): 0


I am using displaylink 4.0.0 drivers.
Johan is offline   Reply With Quote
Old 11-30-2017, 09:16 AM   #67
Carlo
Mac Team
 
Carlo's Avatar
 
Join Date: Feb 2009
Posts: 590
Default

Quote:
Originally Posted by Johan View Post
So I finally got my screens working, but now Im getting logged out everytime I pull the plug on my external screens, when going to meetings with my computer etc. And sometimes when I get back to my desk as well. Everything I was working non gets reset, like connections to vpn, ongoing builds, vnc connections, my virtual machines get super crashed etc.

Really frustrating. Only happens when using the display link screens.

Any progress on this issue?
We're trying to find mitigations. If you haven't done so already, please raise a bug through Apple support or bugreporter.apple.com.

Our bug about these crashes is ID 33650324, Apple's bug is ID 26394372.

Best regards,
Carlo
Carlo is offline   Reply With Quote
Old 12-01-2017, 09:41 AM   #68
maxisan
Junior Member
 
Join Date: Dec 2017
Location: Germany
Posts: 1
Default

My issue is, that i cannot unlock my MacBook Pro with my Apple Watch when i'm connected to my CableMatters USB 3.0 to HDMI Adapter in Black or White Video Adapter.

I'm working with my MacBook Pro (Retina, 15-inch, Mid 2015) with macOS High Sierra 10.13.1, my Apple Watch Series 3, my Henge Dock and 3 DELL monitors.

1 monitor is directly connected via HDMI, 1 through mini displayport and 1 through my CableMatters USB 3.0 to HDMI Adapter in Black or White Video Adapter (SKU 103046 with latest DisplayLink USB Graphics Software for OS X and macOS 4.0.0 drivers).

My system works great but i can't unlock my MacBook with my Apple Watch if it's docked to all monitors.
When i disconnect the CableMatters Video Adapter, everything works fine and i can unlock my MacBook with my Apple Watch.
Without the monitors and undocked, the unlocking works perfect.

I think the problem is the CableMatters Video Adapter. But it works fine with macOS Sierra! After i upgraded to macOS Hight Sierra, the problem appeared.

Some other people have got the same issue: https://discussions.apple.com/thread/7679903
maxisan is offline   Reply With Quote
Old 12-06-2017, 03:34 AM   #69
paultzirides
Member
 
Join Date: Jun 2013
Posts: 37
Default

I think the issue is related to the way Apple is handling secure/protected content when a DL display is connected. It appears that they prevent any secure content from passing to the workstation (HDCP-enabled content, Apple Watch unlock, Apple Pay authorizations, etc.). I seem to recall reading somewhere that this is something that Apple is aware of and is going to be making adjustments to, I just don't know the timeline.

I'm in the same boat. It's frustrating to have to type my (very long) password every time I need to unlock while docked, but I'm adopting a patient approach, since things have been slowly getting better, I'm going to remain hopeful.
paultzirides is offline   Reply With Quote
Old 12-10-2017, 04:36 PM   #70
webtrout
Junior Member
 
Join Date: Dec 2017
Posts: 1
Default

Late to the game here as my org asked us to hold on High Sierra until they could sort out some of the related bugs. Updated to High Sierra 10.13.1 while at the home office last week knowing some have had HS installs go awry.

Upon returning to home office and plugging in the USB it was a no go for my two external monitors - both blank but could mouse into them and it even appeared that I could move move app screens to the monitors but not seeing anything on either. Tested each monitor individually without the adapter in the mix to see if there was problem between HS and the monitors - both monitors worked no problem.

Downloaded the newest version of DisplayLink, loaded it up and still the same problem. Uninstalled DisplayLink, then reloaded the driver and boom I got two externals that I could now see backgrounds for (read not dark). I have been able to extend the displays but have not been able to extend and mirror my MacBook Air to what I use as the primary monitor - upon attempting it flashes, asks me to log into the MBA again but upon logging in all things are the same. Workaround for me is to make one of the external monitors the owner of the menu bar for ease of viewing and use. At this point all is well just which the extend and mirror would work - change is hard .

Any insights as we progress forward are much appreciated.

Computer make: MacBook Air Early 2015
DisplayLink Device: Lenova ThinkPad USB 3.0 Dock Model Number DU9019D1

Version: 4.0.0 (85514)
Last Modified: 12/9/17, 9:35 PM
Bundle ID: com.displaylink.driver.DisplayLinkDriver
Loaded: Yes
Get Info String: DisplayLink Driver 4.0.0 (85514) - Copyright 2003 - 2017 DisplayLink (UK) Ltd. All rights reserved.
Obtained from: Identified Developer
Kind: Intel
Architectures: x86_64
64-Bit (Intel): Yes
Location: /Library/Extensions/DisplayLinkDriver.kext
Kext Version: 4.0.0 (85514)
Load Address: 18446743521823900000
Loadable: Yes
Dependencies: Satisfied
Signed by: Developer ID Application: DisplayLink Corp (73YQY62QM3), Developer ID Certification Authority, Apple Root CA
webtrout is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.