DisplayLink Forum  

Go Back   DisplayLink Forum > Beta Software Testing Programs > Closed Beta Programs > CLOSED: Mac OSX 1.7 Release

Thread Tools Search this Thread Display Modes
Old 08-09-2011, 11:19 AM   #1
Senior Member
Wim's Avatar
Join Date: Feb 2009
Posts: 1,471
Exclamation Important: Known issues between DisplayLink and Lion OSX

The DisplayLink software runs well on Lion, but there is a problem on some Mac platforms. The built-in video driver on certain 2008 and 2009 Macs is incompatible with third-party video drivers. DisplayLink cannot fix this issue, as it is a bug introduced by Apple in Lion. Apple are aware of the problem and we hope they release a fix soon.

We need the community's help to put pressure on Apple to fix these issues and for them to know what pain it is causing their users. The issues are tracked with Apple with bug #9730040.

Symptoms caused by this issue are:
  • The login screen may not be shown
  • When dragging a window, you are unable to drop it
  • Rendering issues on Safari, Quicktime, VLC and possibly other apps

Affected machines include:
  • 13" MacBook (aluminum late 2008, early, mid, and late 2009)
  • 13" MacBook Air (late 2008, mid 2009)
  • 13" MacBook Pro (mid 2009)
  • 15" MacBook Pro (late 2008, 2.53 GHz mid 2009, mid 2009)
  • 17" MacBook Pro (early and mid 2009).
  • 20" iMac (early or mid 2009)
  • 24" iMac (early 2009)
  • 21.5" iMac (late 2009)
  • Mac mini (early or late 2009, Server late 2009)
  • Mac mini Mac OS X Server (late 2009)

A workaround that resolves some issues is to:
  • Go in System Preferences ->Energy Saver
  • Disable "Automatic graphics switching"

Last edited by Wim; 08-10-2011 at 02:27 PM.
Wim is offline  
Old 10-13-2011, 11:36 AM   #2
Senior Member
Wim's Avatar
Join Date: Feb 2009
Posts: 1,471

The 10.7.2 update from Apple today does seem to help with these issues.

Please download and install the 10.7.2 update before reporting any further bugs on Lion.

We do know that the dragging of Windows issue still seems to be present in 10.7.2 and we are reopening this bug with Apple so it gets attention. Please let us know if there are any further issues you find.


Wim is offline  

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT. The time now is 06:32 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.