Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Windows Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-30-2013, 04:27 PM   #1
abstractsimon
Junior Member
 
Join Date: Jan 2013
Posts: 4
Default Dell XPS 13, USB 3.0 and StarTech/Kensington dock

Hi, having problems getting both the StarTech and the Kensington USB 3.0 docks working on our XPS 13 laptops, running Windows 8.

We have 2 XPS 13 laptops and one of each dock. One XPS 13 is a bit older and has a USB 2.0 port as well as a USB 3.0 port, both docks work on the 2.0 port but not the 3.0. The other XPS only has 3.0 ports, so unfortunately works on neither!

I've installed latest drivers but no luck. We were looking to buy a few more of these type of docks for use with the XPS 13, so a bit worried that we're having problems already.

Seems when we plug a dock into an XPS 13 USB 3.0 port the USB 3.0 host device comes up with an error in Device Manager. I've gone to the Intel website to update the drivers but they say they're not available for Win 8 as Win 8 has built in drivers.

Any suggestions?
abstractsimon is offline   Reply With Quote
Old 01-30-2013, 04:59 PM   #2
abstractsimon
Junior Member
 
Join Date: Jan 2013
Posts: 4
Default

I managed to get it working on the older XPS 13's USB 3.0 port, by installing the updated Fresco Logic drivers, I didn't realise at first that it differed to the newer XPS device in this way. The newer XPS 13 however has Intel drivers and we're unable to update these as explained in the original post.

Last edited by abstractsimon; 01-30-2013 at 05:30 PM.
abstractsimon is offline   Reply With Quote
Old 01-30-2013, 08:58 PM   #3
luiset83
Member
 
Join Date: Feb 2012
Posts: 48
Default

Sounds like you'd benefit from what this other user posted:

http://www.displaylink.org/forum/showthread.php?t=2336
luiset83 is offline   Reply With Quote
Old 01-31-2013, 10:44 AM   #4
abstractsimon
Junior Member
 
Join Date: Jan 2013
Posts: 4
Default

That didn't work for me, however I followed the instructions below and this fixed it.

http://plugable.com/2012/12/01/windo...st-controllers
abstractsimon is offline   Reply With Quote
Reply

Tags
dell, kensington, startech, windows 8, xps13

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.